Support » Plugin: Packlink PRO shipping module » CPU overload due to plugin

  • Resolved Manuel

    (@mmichiels)


    I had to deactivate plugin due to CPU overload created by the plugin
    Where can I share confidencial info about website with support?

Viewing 15 replies - 1 through 15 (of 23 total)
  • Plugin Author packlink

    (@packlink)

    Hi,

    our pluggin is launching several call per minute in order to update the orders status tracking…

    This cause in some server a surcharge. The issue is if we don’t realise those calls our users will not have the data in live.

    Packlink

    @packlink As an idea:

    Maybe you need to create some options for us to select the refresh period and this don’t cause server overload. Or maybe modify this period by a hook.

    Maybe:
    -1 minute
    -5 minutes
    -10 minutes
    -etc…

    In most cases we don’t need to update in a minute to minute interval, causing too many calls without purpose.

    Thank you.

    mercurio32

    (@mercurio32)

    CPU management of this plugin is very serious. I only discovered excessive CPU usage when it was too late. The sites were banned from hosting due to exceeding monthly CPU usage. Something like this has never happened with any plugin.
    Users should at least be warned, but it is an unjustified CPU use, just a manual key to synchronize the data.

    Deactivated immediately.

    Hello, is there any chance to address this issue? I also had a very serious issue with my hosting due to excessive CPU usage. We cannot use the plugin AT ALL because the number of calls is just enormous and not justified.

    Hello, is there a way to receive an update on this, either way? We currently have deactivated the plugin and cannot use it until this is fixed, because the hosting is banning our website. If nothing can be done here we are going to move to another service.

    @mercurio32 @veecious It seems that the plugin creator doesn’t seem to realize the importance of this issue. We need your attention @packlink here.

    The CPU overload is because your 1 minute update, please consider my past comment on letting us users to manage the update interval. This could be done by placing an option or even modifying it by a function/hook.

    @danidub @mercurio32 @veecious fully agree with everybody. I had to disable the plugin after several warnings from my hosting service.
    @packlink developers should implement any kind of solution like the ones proposed by @danidub.

    @mmichiels can you mark this ticket as unsolved for @packlink to take some action on this issue?

    Plugin Author packlink

    (@packlink)

    Hi,

    Sorry for the delay

    The Packlink module performs certain actions in the background. Such actions include refreshing lists of available shipping methods, uploading order details to Packlink, updating order status in a shop, etc.

    To check if there is a background action that should be performed the module sends a single web request to itself. This web request is sent once every 5 seconds. It is a very high-performance request that in the vast majority of shops has no detectable impact on performance.

    Packlink team

    We all are at that point. Glad you are aware of the problem now. Are you going to do anything about it? Any plans to get this solved? We users are banging our heads on a wall due to this!

    For a site like Amazon the impact is irrelevant, while for all other sites it is an impact that should be saved. The packlink plugin consumes more resources than 4000 daily users, why waste so much hosting resources?
    For eBay, in fact, the system is very different, make a manual request from packlink when needed, the same should be done with woocommerce, access packlink and with a manual request import all shipments “in progress”.
    In the absence of help from packlink the only way is to deactivate the plugin and activate it only when needed.

    This is also wasting so much energy on doing nothing but updating all day long even if there are no purchases… Please, how can you tell your plugin is doing “very high-performance request”. This seems to be a REALLY LOW PERFORMANCE PLUGIN.

    Plugin Author packlink

    (@packlink)

    Hi,

    We can growth the call response from 5 seg to 1 min. For the requesters. For that you neeed to contact your Packlink Agent.

    Regards

    Alguien ha conseguido resolver el problema? estoy igual he tenido que desactivarlo por el alto consumo y he tenido que ampliar mi plan para no tener la tienda cerrada

    @encolorespastel el problema es que @mmichiels ha cerrado el hilo y está como resuelto, por lo tanto no van a responder sobre esto, ni sabremos si esto avanza o no… Quizá hay que abrir nuevamente un hilo y no cerrarlo hasta que lo solucionen.. Si por casualidad abres uno nuevo, pega aquí el enlace en una respuesta así podemos seguirlo.

Viewing 15 replies - 1 through 15 (of 23 total)
  • You must be logged in to reply to this topic.