Forums » Plugin: The SEO Framework – Fast, Automated, Effortless. » CPTs not listed in sitemap

  • Resolved vallered

    (@vallered)


    Hello,

    as follows:
    my cpt “collection” is not excluded within TSF, but when generating the sitemap thru TSF, they are missing. Am I missing a point/ setting to make that happen?

    The page I need help with: [log in to see the link]

Viewing 6 replies - 1 through 6 (of 6 total)
  • Thread Starter vallered

    (@vallered)

    solved, as I previously had excluded these cpts in TSF settings, switching that back did not work (maybe a little bug of TSF). I had to switch TSF’s performance settings from storing in database to managing in websites to make that re-change work, now my cpts are generated with the sitemap by TSF.

    • This reply was modified 1 year, 7 months ago by vallered.
    Plugin Author Sybre Waaijer

    (@cybr)

    Howdy! I’m glad you found a workaround to this issue.

    From the looks of things, it seems you hit a caching issue, where resaving the SEO settings resolved it.

    However, I did find that when a post has “Exclude from Archive” enabled, with the Performance option “Enable archive query alteration” set to “In the database” (like you had), the post won’t show up in the sitemap.

    Could you please confirm the CPT collection posts had “Exclude from Archive” checked at edit post’s “Collection SEO Settings -> Visibility -> Archive Settings”?

    Thread Starter vallered

    (@vallered)

    No, caching issue could be excluded, I deactivated the litespeed caching before doing a couple of changing and saving attempts. And no, archive is enabled for that cpt in the seo settings.

    Plugin Author Sybre Waaijer

    (@cybr)

    Thank you for the feedback!

    Post SEO Settings TSF

    To be clear, is the checkbox defined in the image above “unchecked”?

    Thanks to your comments earlier, I found unintended behavior related to that option, but I couldn’t reproduce the issue you’re facing otherwise: https://github.com/sybrew/the-seo-framework/issues/610.

    Enabling a disabling option; is that checking or unchecking…? This type of verbatim is my nemesis 😅. Maybe I should upend that option’s value and description.

    Thread Starter vallered

    (@vallered)

    yes, it is unchecked on my CPTs, and it has always been. The issue must be generated when disabling indexing of that CPT and its archive within TSF (that’s what I did earlier), and then enabling that again. But I can’t remember, what steps in what sequence I made within TSF exactly

    Plugin Author Sybre Waaijer

    (@cybr)

    Thanks for verifying and for additional debugging.

    Yes, posts that aren’t indexable aren’t listed in the sitemap. TSF also holds a cached copy of the sitemap: perhaps it failed to clear earlier due to an unspecified error (plugin conflict, server outage, cosmic ray event, etc.).

    I think it’s best to mark this issue as a “fluke,” but I’ll keep an eye out for similar reports.

    Have a nice day!

Viewing 6 replies - 1 through 6 (of 6 total)
  • The topic ‘CPTs not listed in sitemap’ is closed to new replies.