Support » Plugin: Custom Taxonomy Order » CPT UI incompatibility?

  • alantygel

    (@alantygel)


    Hi,

    I need to reorder my taxonomies, specially regarding the order that their metaboxes appear on the custom post edit form.

    My taxonomies were created using CPT UI. After reordering it using Custom Taxonomy Order, nothing happens.

    Is there any know incompatibility? Regarding another plugin that does not tackle this issue, I found this: https://wordpress.org/support/topic/taxonomy-must-be-registered-to-work/. But this solution did not work either.

    Thanks,
    alan

Viewing 5 replies - 1 through 5 (of 5 total)
  • Plugin Author Marcel Pol

    (@mpol)

    Hi,
    I just tested, and the terms are sorted. These were my steps:

    – Create CPT ‘test”
    – Create taxonomy ‘test’ which is hierarchical
    – Create terms in that taxonomy
    – Custom sort these terms, and set setting to use custom sort
    – Go to new post, and the postbox has terms that are sorted

    If you are talking about the taxonomy themselves, I see the same. Sorting the postboxes is not being done. I will see if I can give a better answer.

    Plugin Author Marcel Pol

    (@mpol)

    That is quite a maze to go through 🙂

    I don’t see a way to filter the order of taxonomy postboxes.

    The function ‘get_object_taxonomies’ in /wp-includes/taxonomy.php is being used, which doesn’t have a filter.
    The metaboxes are being added with the function ‘register_and_do_post_meta_boxes’ in /wp-admin/includes/meta-boxes.php, which doesn’t filter the taxonomies either.

    alantygel

    (@alantygel)

    Crazy… such a simple thing could not be so complicated!

    This problem happens only with CPT UI?

    Plugin Author Marcel Pol

    (@mpol)

    I think it happens with every taxonomy.

    Not sure if a ticket for WordPress will help. I can take a look if there could be a filter added, and request that on trac.

    Plugin Author Marcel Pol

    (@mpol)

Viewing 5 replies - 1 through 5 (of 5 total)
  • You must be logged in to reply to this topic.