Support » Plugin: Pods - Custom Content Types and Fields » cpt leave pods template on filter

  • Resolved ferryvb6

    (@ferryvb6)


    Hi,

    I try to apply a filter on a custom post type by pods on taxonomies created with pods but as soon i apply the filter (tried several) the search loses the pods template and returns a empty page or switch the the default WordPress archive template.

    The filters add ” ?post_type=postypename/searchquery ” to the link or return the default WordPress archive excluding the pods template.

    Is there a way to fix this or work around?
    I want to be able to filter by taxonomy and if possible preform a search to the posttype. (filter is the most important)

    Permalink is set to id
    No default WordPress fields, only pods

    I tried search & filter, Beautiful Taxonomy Filters and lots of others.

    Thanks in advance

Viewing 1 replies (of 1 total)
  • Plugin Author Jim True

    (@jimtrue)

    Are you using the Archive for the Custom Post Type? All taxonomy filters require you to have a post type archive enabled under Pods Admin, Edit Pods, your Pod, Advanced Options tab, Enable Archive.

    If you’re using a WP Page and a shortcode for the “archive”, it won’t work because taxonomy archives and filters require you to use an actual WP post type archive. FacetWP has Pods Integration and you can feed a Pods Template to the loop using this process:
    https://docs.pods.io/plugins/facetwp/

Viewing 1 replies (of 1 total)
  • You must be logged in to reply to this topic.