Support » Plugin: UpdraftPlus WordPress Backup Plugin » cPanel Cron Job

  • Resolved temporalnaut

    (@temporalnaut)


    After turning off WordPress cron jobs and turning on Cron jobs in the cPanel on the server (running every 16 minutes), Updraft started fooling around. I have set up sending backups to Google Drive (last 3 backups: Database, Plugins, Themes, Uploads, Others = 3GB), which works, but Updraft does not delete all old backups and I have to delete them manually. In WordPress on the main page of Updraft Plus I see the message: Warning: WordPress has a number (7) of scheduled tasks which are overdue..
    Hosting Technical Support has told me that they do not see the problem and Cron actually logs every 16 minutes according to the logs.
    I am attaching a screenshot from Google Drive, where it is possible to see old backups that were partially deleted by Updraft, but most of the parts remained.
    It should be noted that I also have problems with publishing scheduled articles and about 1 in 10 will not be published and will get the status Missed schedule (and it is not published even after 16 minutes). Can you help me with that, please?

    The page I need help with: [log in to see the link]

Viewing 9 replies - 1 through 9 (of 9 total)
  • Plugin Contributor bcrodua

    (@bcrodua)

    Hi,

    It sounds like your WordPress scheduler may be broken.
    To confirm this, can you install a plugin called WP-Crontrol? This will allow you to see all scheduled tasks that WordPress is handling.
    Then could you navigate to Tools->Cron Events, and send me a screenshot of that page? We’ll be able to work out if the scheduler is working correctly.

    We also have a guide to this issue in our FAQs here. This provides some further advice that you can try.

    Best Wishes,
    Bryle

    I can see that there are also things from already uninstalled plugins.
    https://imgur.com/a/uwwkJC5

    I cleaned the cron jobs and the database, so in a few days I will know if the problem persists.

    temporalnaut

    (@temporalnaut)

    So, the problem occurs again, I’m sending a screenshot from WP-Crontrol

    Plugin Contributor bcrodua

    (@bcrodua)

    Hi @temporalnaut

    Thank you for sending a screenshot.

    It shows a warning messag. Please could you check the wp-config.php file for the following line:
    define(‘DISABLE_WP_CRON’, true);

    If this is present, please change ‘true’ to ‘false’.

    If not, please could you add the following line of code:
    define(‘ALTERNATE_WP_CRON’, true);

    This will enable the alternative cron system. Then, reload the WP dashboard page a few times. The list of scheduled tasks should reduce.
    Then, could you ask your hosts if ‘loopback connections’ are disabled on the server?

    Best Wishes,
    Bryle

    temporalnaut

    (@temporalnaut)

    Hi, but my hosting provider recommends
    define (‘DISABLE_WP_CRON’, true);
    if i want to use cpanel cron jobs.. so then i don’t know what is right now. Nevertheless, I removed it from wp-config yesterday and added only:
    define (‘ALTERNATE_WP_CRON’, true);
    Hosting support has confirmed to me that ‘loopback connections’ are turned on. I’m sending a new screenshot from WP control.

    After a few days, I noticed that older backup files started remaining on Google Drive again. I see 4 files from 2 previous days (I use splitting into smaller zip archives with a size of 50mb and it is backed up once a day). New screenshot from wp-control.

    Plugin Contributor bcrodua

    (@bcrodua)

    Hi,

    Apologies for the late reply.

    Will ask one of my colleagues to check on this.

    Best Wishes,
    Bryle

    Hi,
    I have reduced the number of backups stored on GDrive to 2, it’s been about two weeks and everything works OK (maybe you fixed something, because I always use the latest version).

Viewing 9 replies - 1 through 9 (of 9 total)
  • You must be logged in to reply to this topic.