Support » Fixing WordPress » cpanel and addon domain 404 problems

  • werelax

    (@werelax)


    I am looking for help getting my wordpress installation working in the main domain without messing up my application in an addon domain. I think the problem is in the default htacess file that was installed with wordpress.

    I have my WP site on a domain in the root directory http://www.mysite-wp. com. The host installed it. Works fine. BUT I have another site non-wp in an addon domain created in cpanel http://www.mysite-addon. com.

    That site was returning a header status of 200 for pages that did not exist instead of the expected 404 and redirecting to the mysite-addon. com index page. (real problem – google would not verify the account for any of their services)

    when I removed the default rewrite commands that were installed with my orginal wordpress installation mysite-addon. com served up a 404 error and the 404 custom page as expected.

    But then main domain http://www.mysite-wp. com comes up with the defualt 404 error page, not the one in the theme.

    Here is the code that was there with the original installation.

    # BEGIN WordPress

    <IfModule mod_rewrite.c>

    RewriteEngine On

    RewriteBase /

    RewriteCond %{REQUEST_FILENAME} !-f

    RewriteCond %{REQUEST_FILENAME} !-d

    RewriteRule . /index.php [L]

    </IfModule>

    # END WordPress

    the actual domains are http://www.we-relax.com (main) and http://www.sequimads.com in the addon domain. htacess is back to original state.

  • The topic ‘cpanel and addon domain 404 problems’ is closed to new replies.