Support » Plugin: Gutenberg » Cover default heading color

  • Hi @paaljoachim

    Default color set for headings in theme do not apply on the front when heading are in cover.
    If heading are pushed out of cover, default heading color applies, i dragged and drpped in cover, default headings color is not any more

    Is it a known issue or is it them related issue ?

    Thanks

    Regards

    Johan

Viewing 5 replies - 1 through 5 (of 5 total)
  • Plugin Support Paal Joachim Romdahl

    (@paaljoachim)

    Hi @johan_walter

    Testing with WordPress 5.8 RC4 (5.8 will be released on the 20th of July).
    Theme: Twenty Twenty One.
    Gutenberg plugin not activated.

    I added a Cover block with a background image.
    Transformed the current paragraph block inside the Cover block to a Heading block. (I also tested with adding another Heading block).
    Added some text.
    Added background color to the Heading block.
    I was able to see the background color of both Heading blocks.

    I would suggest creating a development site (if you have not already done so) then switching from your theme to Twenty Twenty One, and retesting there.
    If it works in Twenty Twenty One (or another default theme) then it might be a theme issue.
    Check and see if you are using a default Gutenberg Heading block or a Heading block from a plugin. If you are using a Heading block from a plugin then test a default Heading block.

    Thread Starter Johan WALTER

    (@johan_walter)

    Hi @paaljoachim

    I do have a staging website to make testing
    I just did a test switching to Twenty Twenty one, I met the same issue.

    I don’t find a way in Twenty Twenty one to set default color for headings so I set it in custom css
    The heading H1 (SOINS ESTHETIQUES) is still white
    Screenshot https://ibb.co/C0hxyN0

    I duplicated this heading and drag and drop out of cover. Default color applied on H1
    Screenshot https://ibb.co/4McksPn

    Here is screenshot with my theme, you can see that color by default is applied in preview in back but do not apply on the front
    BACK https://ibb.co/m0tTzvM
    FRONT https://ibb.co/1zZfVyj

    Testing you did seems to have applied color manually on heading, this indeed works, my issue concerns default color.
    I guess there is an issue on headings to take default color (set in template or set in custom css) when heading are in a cover
    What do you think ?

    • This reply was modified 2 months, 1 week ago by Johan WALTER.
    • This reply was modified 2 months, 1 week ago by Johan WALTER. Reason: Add screenshot of default color on my theme
    Plugin Support Paal Joachim Romdahl

    (@paaljoachim)

    I think you should test WP 5.8 after the release tomorrow and add another comment.

    Thread Starter Johan WALTER

    (@johan_walter)

    Hi @paaljoachim

    I have tested again with WP 5.8, Gutenberg 11.1.0, Twenty Twenty one theme
    A color set for heading in custom css, I made example with h1
    Heading H1 in COVER do not take the color set in custom css on the front but it does show the color in the back
    I duplicate h1, drag and drop out of cover, color is applied on the front and in the back

    Same happen for color set by default in theme when I switched to my theme

    Plugin Support Paal Joachim Romdahl

    (@paaljoachim)

    Hi @johan_walter

    I just tested with WP 5.8.1, Gutenberg 11.5 and Twenty Twenty One.
    Added custom css to change the color to red.
    Added the css to a Paragraph block and Heading block outside and inside a Cover block. I could see the change on the Frontend but not on the Backend.
    It seems like a bug to me. I asked about it in the core themes channel on Slack and might have to open an issue here: https://github.com/WordPress/gutenberg/issues

    Btw I appologize for the late response. I totally forgot about this thread.

Viewing 5 replies - 1 through 5 (of 5 total)
  • You must be logged in to reply to this topic.