• Resolved hanygamal

    (@hanygamal)


    Hi, the course information appears twice on the course page! I tried everything – without coding- and nothing happens.
    I use Astra theme, and of course wordpress 5.0.2

    Thanks.

    The page I need help with: [log in to see the link]

Viewing 8 replies - 1 through 8 (of 8 total)
  • Using Classic Editor You have to remove sections looking like comments (<——-simething—–>)from content in the edit window.

    Screenshot

    Plugin Author Thomas Patrick Levy

    (@thomasplevy)

    @hanygamal,

    @jurasjo is correct, we’ve opted not to “unmigrate” back to the Classic Editor. If you installed 5.0 and used the block editor and then decided to move back to the Classic Editor you need to remove the remnants of the blocks added during the 5.0 migration.

    Let me know if that helps

    The Classic Editor plug in was causing this, I deactivated and problem solved. Thanks guys.

    I’m experiencing the same problem and a random occurrence, but I am not using the Astra theme.

    I am using the Classic editor plugin, though, but deactivating it does not resolve the issue.

    Opening the affected lesson, switching from and back again to Block editor and then updating the lesson gets everything back to the normal state. Not an ideal solution for anyone with a lot of lessons, but a temporary fix if you’re short on time.

    Plugin Author Thomas Patrick Levy

    (@thomasplevy)

    @wplms24,

    Could you let me know if 3.26.4 fixes this issue for you?

    Hello,

    I am uploading a course at the moment and some of the layout info appears twice on lessons.

    I’ve searched the threads and only found this one similar.

    Thanks!

    Plugin Author Thomas Patrick Levy

    (@thomasplevy)

    @jhenwood,

    If you’ve recently upgraded to WordPress 5.0, “migrated” to the block editor and then switched to the classic editor you very likely have some stray “block” code on your site that WordPress still renders even when the classic editor plugin is installed.

    You’ll want to head to your lessons and then remove the block code by switching to “TEXT” mode on your editor and looking for the following pieces of block code:

    <!-- wp:llms/lesson-progression /--> and <!-- wp:llms/lesson-navigation /-->

    @thomasplevy

    Not sure if the upgrades to LifterLMS since my last post here helped or not, because I found a way to resolve this soon after posting. šŸ™‚ The solution also took care of the issue with the missing (Mark Lesson as Complete) button and Lesson Navigation mentioned here.

    And, it also automatically took care of the issue you mentioned with leftover block code, so I didn’t have to go to each lesson and manually delete each remnant of code. Perhaps the filter to disable Gutenberg took care of it automatically? I cannot say for sure…

    Anyway, I’ve outlined the steps I took in the other thread and will link to them here to avoid repetition.

Viewing 8 replies - 1 through 8 (of 8 total)
  • The topic ‘Course information appears twice on the course page’ is closed to new replies.