• Resolved dennishall


    In LifterLMS > Settings > Courses, the “Courses per page” setting does not work.
    If I change this setting, that number of courses displayed in the Dashboard > My Courses reflects the number of courses, but not the Course Catalog. The course catalog only shows 5 courses no matter what number is entered in the LifterLMS > Settings > Courses > Courses per page field.

    I have also found that in the Dashboard > My Courses, when I have more courses than the “Courses per page” setting, the My Courses pagination does not work.

    There are no server-side or caching plugins installed and host server cache is, and always has been, disabled.
    Example to reproduce the issue:
    Set the “Courses per page” to a number less that the number of courses a user is enrolled into.
    Visit the Course Catalog to see if the number of courses displayed per page has changed.
    Result: no.
    Visit the Dashboard > My Courses partial.
    Verify the number of courses displayed in the first view is less than the total number of courses the user is enrolled into.
    Select the 2nd. page or the Next button.
    Result: these links to not work.

    It was already proposed to use the [lifterlms_courses] shortcode with atts, but this does not display the courses in the desired order, yet the LifterLMS > Settings > Courses settings does.
    The problem with the shortcode is that is uses the post_id making courses be listed in order of creation rather than use the Post Attributes > Order number.

    LifterLMS Version 3.36.2

    The page I need help with: [log in to see the link]

Viewing 6 replies - 1 through 6 (of 6 total)
  • Plugin Support Natalie


    Hi @dennishall,

    I’m sorry you’re having this issue!

    Thank you for the recreation details! However, we were not able to recreate this on our test sites! Could you provide us with you System Report: https://lifterlms.com/docs/how-to-use-the-lifterlms-system-report/ (following WordPress’s guide for code: https://wordpress.org/support/forum-user-guide/faq/#i-need-to-post-code-is-that-okay) so we can review further details that may be affecting the course catalog?

    That said, the number of courses you have set to display in the course catalog should not be affecting the Student Dashboard. Can you send us some screenshots of the issue you’re seeing on the Student Dashboard with pagination?

    Additionally, if you prefer to use the shortcode ( https://lifterlms.com/docs/shortcodes/#lifterlms_courses ) you can change the orderby option to arrange by: ID, author, title, name, date, modified, rand, or menu_order.

    Let us know if you have any questions about finding any of the above information for us!

    Thanks and take care,



    I repeat: Your shortcode is useless because it only uses the post_id and not the Oder ID (which can be configured). Not an option.

    Staging site with only LifterLMS plugins enabled and no Divi child-theme enabled.
    This is as bare-bones as it gets and clearly demonstrates the LifterLMS course catalog number of courses displayed is not being respected.

    LifterLMS System Report:
    Home Url: https://www.domain.com/staging
    Site Url: https://www.domain.com/staging
    Login Url: https://www.domain.com/staging/wp-login.php
    Version: 5.2.4
    Debug Mode: No
    Debug Log: No
    Debug Display: Yes
    Locale: en_US
    Multisite: No
    Page For Posts: Not Set
    Page On Front: Home (#5) [https://www.domain.com/staging/]
    Permalink Structure: 
    Show On Front: page
    Wp Cron: Yes
    Version: 3.36.2
    Db Version: 3.36.2
    Course Catalog: Courses (#178) [https://www.domain.com/staging/?page_id=178]
    Membership Catalog: Membership Catalog (#3842) [https://www.domain.com/staging/?page_id=3842]
    Student Dashboard: Dashboard (#3844) [https://www.domain.com/staging/?page_id=3844]
    Checkout Page: Purchase (#3843) [https://www.domain.com/staging/?page_id=3843]
    Course Catalog Per Page: 24
    Course Catalog Sorting: menu_order,ASC
    Membership Catalog Per Page: 12
    Membership Catalog Sorting: menu_order,ASC
    Site Membership: Not Set
    Courses Endpoint: my-courses
    Edit Endpoint: 
    Lost Password Endpoint: 
    Vouchers Endpoint: 
    Autogenerate Username: yes
    Password Strength Meter: yes
    Minimum Password Strength: strong
    Terms Required: no
    Terms Page: Not Set
    Checkout Names: required
    Checkout Address: required
    Checkout Phone: optional
    Checkout Email Confirmation: yes
    Open Registration: no
    Registration Names: required
    Registration Address: optional
    Registration Phone: hidden
    Registration Voucher: optional
    Registration Email Confirmation: no
    Account Names: required
    Account Address: required
    Account Phone: optional
    Account Email Confirmation: yes
    Confirmation Endpoint: confirm-payment
    Force Ssl Checkout: no
    Country: US
    Currency: USD
    Currency Position: left
    Thousand Separator: ,
    Decimal Separator: .
    Decimals: 2
    Trim Zero Decimals: no
    Recurring Payments: no
    Email From Address: admin@domain.com
    Email From Name: Domain
    Email Footer Text: 
    Email Header Image: 
    Cert Bg Width: 800
    Cert Bg Height: 616
    Cert Legacy Compat: no
    Manual: Disabled
    Manual Logging: 
    Manual Order: 1
    Mysql Version: 5.6.40
    Php Curl: Yes
    Php Default Timezone: UTC
    Php Fsockopen: Yes
    Php Max Input Vars: 3000
    Php Max Upload Size: 128 MB
    Php Memory Limit: 768M
    Php Post Max Size: 128M
    Php Soap: Yes
    Php Suhosin: No
    Php Time Limt: 120
    Php Version: 7.2.22
    Software: Apache
    Wp Memory Limit: 128M
    HTTP USER AGENT: Mozilla/5.0 (Windows NT 10.0; Win64; x64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/77.0.3865.120 Safari/537.36
    Name: Divi
    Version: 4.0.2
    Themeuri: http://www.elegantthemes.com/gallery/divi/
    Authoruri: http://www.elegantthemes.com
    Child Theme: No
    Llms Support: No
    LifterLMS: 3.36.2
    LifterLMS Labs: 1.5.2
    WP Staging: 2.6.3
    BbPress: No
    BuddyPress: No
    Template Overrides

    As previously mentioned, the lifterlms_catalog shortcode is useless because you use the post_id and not the post order number – so no control over the sorting.

    With only LifterLMS, ListerLMS Helper and ListerLMS Labs enabled, the Course Catalog Per Page: 24 setting still only display 5 courses in the course catalog page.
    The Student Dashboard located at: https://www.domain.com/staging/?page_id=3844&my-courses is also still showing up to 24 courses.

    • This reply was modified 12 months ago by Jan Dembowski.
    • This reply was modified 12 months ago by Jan Dembowski. Reason: Formatting
    Plugin Contributor Rocco Aliberti


    Hi Dennis,
    the issue you’re experiencing in the Course Catalog is a conflict with the Divi theme.
    Basically the Divi theme overrides the number or courses displayed in the Course Catalog page with its option Number of Posts displayed on Archive pages that you can change from your dashboard -> Divi -> Theme Options

    I’m not able to reproduce the other issue you’ve reported:

    I have also found that in the Dashboard > My Courses, when I have more courses than the “Courses per page” setting, the My Courses pagination does not work.

    works fine here…



    Thanks. That resolved both the course catalog and the dashboard / my courses issue.

    Plugin Contributor Rocco Aliberti


    Hi Dennis,
    I’m glad you solved!


    Plugin Author Thomas Patrick Levy


    We’re changing the core priority of our filters to avoid this conflict (and potentially other conflicts: https://github.com/gocodebox/lifterlms/pull/970

Viewing 6 replies - 1 through 6 (of 6 total)
  • The topic ‘Course Catalog does not respect settings’ is closed to new replies.