Support » Plugin: WooCommerce » Coupons Not Applying

  • Resolved chumidor

    (@chumidor)


    I’m not sure how long this issue has been happening but today I tried to use a test coupon I had to resolve a customer checkout issue and noticed that after I put in the coupon code and click Apply, I just get this endless wheel that spins and spins. There’s 3 different areas you can put in a coupon code and none of them work. I tried using existing coupons that vary from % off to $ off and nothing works. I disabled some plugins that work on the cart level but that didn’t change anything. Does anyone have any suggestions? I’ve exhausted the web for solutions and I’m not finding anything.

    The page I need help with: [log in to see the link]

Viewing 6 replies - 1 through 6 (of 6 total)
  • Plugin Support abwaita a11n

    (@abwaita)

    Hi @chumidor,

    I disabled some plugins that work on the cart level but that didn’t change anything.

    As this issue could have been caused by a conflict between WooCommerce and another plugin or your theme, I would recommend doing a full conflict test to see if you can find the culprit – https://docs.woocommerce.com/document/how-to-test-for-conflicts/.

    If the conflict test above does not bring up anything, kindly share with us a valid coupon code that we can try testing with.

    Thanks.

    Thread Starter chumidor

    (@chumidor)

    Does someone else have a suggestion besides the normal disable all your plugins etc response? I only have 1 day out of the week to resolve any issues or put new products on my website and the above response requires way more time than I normally get. I’ve created a staging site but for some reason the only pages that are show as a staging site is the dashboard and the homepage. Every other page including where I am having this issue takes me to the live site.

    Thread Starter chumidor

    (@chumidor)

    Also, in the staging area I pretty much disabled anything I didnt absolutely need and even updated the theme and that changed nothing. So here is a coupon you can use on the live site, V6BUNUYJ on any item but I’m not sure how helpful it will be considering it doesnt do anything but spin 🙁

    Plugin Support B C. a11n

    (@battouly)

    Hey @chumidor,

    To better understand what’s happening, I’d like to take a look at your site’s logs.

    To find the generated logs:

    1. Go to WooCommerce > Status > Logs
    2. Copy/paste the relevant part of the log (any logs with a fatal or critical error) into your response, so we can take a look.`

    It will be great if you could share your current System Status Report too. You can get it by navigating to the WooCommerce / Status section of your site. Once there, click on the Get system report button and then copy it by clicking on the Copy for support button. Then paste it here in a comment.

    Thread Starter chumidor

    (@chumidor)

    FYI, I have resolved this problem. If you are using WooDiscount plugin, go to Settings>scroll to the bottom where it says Third Party Plugin coflicts and fixed and toggle the option that says Disable re-calculating the total when applying the coupon to YES. This resolved the coupons not applying. All seems to work fine now

    Plugin Support abwaita a11n

    (@abwaita)

    Glad to hear you solved it!

    Thanks for sharing the fix that worked in your case.

    I’ll go ahead and mark this thread as resolved now. If you have any further questions, I recommend creating a new thread.

Viewing 6 replies - 1 through 6 (of 6 total)
  • You must be logged in to reply to this topic.