Support » Plugin: WooCommerce » Coupon management has moved! – notice

  • Resolved koullis

    (@koullis)


    with new update this noticed popped up in order and products. i clicked the option but the notice is still there. coupon option is at the new location but notice keep popping up

    This is the notice which cant be cleared

    “”Coupon management has moved!
    Coupons can now be managed from Marketing > Coupons. Click the button below to remove the legacy WooCommerce > Coupons menu item. –Remove legacy coupon menu “”

    any way to remove this notice entirely?

    regards

    • This topic was modified 11 months, 1 week ago by .
Viewing 15 replies - 1 through 15 (of 32 total)
  • Nancy

    (@nancythanki)

    Hi there! Can you confirm that your browser and site cache are cleared? If they are, can you share a screenshot of the notice you’re seeing?

    I recommend https://snipboard.io for easily sharing screenshots – please follow the instructions on the page, then paste the URL in your response. It works with Chrome, Firefox, Safari, and Edge.

    Thread Starter koullis

    (@koullis)

    im using latest 4.4.1 now and still notice is there

    im not sure it it has anything to do but I also noticed site its slower since the update 4.4.0.

    here is the screenshot

    https://snipboard.io/j7ezFq.jpg

    coupon menu is already under “marketing”

    Thread Starter koullis

    (@koullis)

    @nancythanki any way to remove it? or stop showing up? coupon menu is already moved

    The coupon is bugged just like the woocoomerce admin bug.

    Thread Starter koullis

    (@koullis)

    @jokerfool seems this release was released too early…seeing many problems in support..hopefully will be fixed soon

    elankathir

    (@elankathir)

    Yes, we do have this notice issues with coupon and WC database update..,

    1. Coupon management has moved!
    2. WooCommerce database update done

    We are using the following code to hide the admin notice (quick, but not right solution)

    add_action( 'admin_head', 'admin_css' );
    function admin_css() {
    echo "
    <style type='text/css'>.is-alert-update {display: none;}</style>
    ";
    }

    Code Reference: https://wordpress.org/support/topic/from-3-8-to-4-01-woocommerce-database-update-done-wont-go-away/

    But we need a permanent fix for this issue on the WC plugin.

    inspired888

    (@inspired888)

    Same issue. Can’t get the “Remove legacy coupon menu” notification to go away.
    Also noticed the WC Database update completed notification was hard to make go away (required multiple attempts).
    Clearing browser cache doesn’t help.
    This is on Firefox Developer Edition 80.0b8 (64-bit)

    Nazar Hotsa

    (@bugnumber9)

    I can confirm the issue.
    Cleaned cache, cookies, used a different browser and even tried a different computer 🙂
    This is clearly a bug.

    Thread Starter koullis

    (@koullis)

    @elankathir Thank you for the temp solution. It works but you can still see that tries to load it before disappearing. Hopefully a fix will arrive soon

    • This reply was modified 11 months ago by .

    Try this if you are familiar with SQL and Database,

    1. Connect to the SQL WordPress Database
    Refer: https://docs.bitnami.com/aws/apps/wordpress-multisite/get-started/access-phpmyadmin/

    2.1 Update the record related to “Update” (Single Site)
    UPDATE wp_wc_admin_notes SET status='actioned' WHERE type = 'update';

    2.2 Update the record related to “Update” (Multi-Site)
    Replace <SiteID> with your respective Site ID (Means different table for different site in the Multi-Site Installtion like wp_2_wc_admin_notes)
    UPDATE wp_<SiteID>_wc_admin_notes SET status='actioned' WHERE type = 'update';

    Note : Use SELECT statement to check the record status before making changes (Select * from wp_wc_admin_notes WHERE type = 'update')

    Here too.

    Plugin Support Doug – a11n

    (@dougaitken)

    Automattic Happiness Engineer

    Hi all –

    Are you still seeing this notice active?

    If you click into the new Coupons page then navigate away, does the banner still show?

    Thanks,

    I’m fairly new to WooCommerce, but this and similar seems to happen every time there’s an update, and is resolved by:

    UPDATE wpdc_wc_admin_notes SET status='actioned' WHERE type = 'update';

    It’s tempting to just put that update in crontab, since this seems to routinely not work. You click to dismiss the notice, but nothing happens.

    Thread Starter koullis

    (@koullis)

    while i was using code from @elankathir decided to disable it to check after an update was made (dont remember what) now notice disappeared.

    This worked for me:

    open PHPMYADMIN and go to the database.

    search for wp**_wc_admin_notes. Next, In the list find wc-admin-coupon-page-moved

    (remember to replace ** with your own database prefix)

    edit and change “unactioned” to “actioned

    click GO

    joy joy joy

    NOTE: If you are not familiar with PHPMYADMIN do not try this. As always, backup your database before making any changes.

    Thanks Woo for making our hectic days easier

    • This reply was modified 10 months, 2 weeks ago by SSVapes.
Viewing 15 replies - 1 through 15 (of 32 total)
  • You must be logged in to reply to this topic.