Support » Theme: Exoplanet » Couple questions – hero images and featured services

  • http://www.ThunderRidgeMC.org

    I just started playing with this theme on a new site…for the most part, I think I like it 😉

    One thing that seems odd that I can’t seem to figure out is that when I set pages for the hero section on the home page, which have appropriately-sized photos attached as the featured image, what shows up on the hero section seems like a notably lesser quality photo – with or without the darkening overlay. And I’m not using any pattern overlay. The photos themselves in the media library look fine – but it’s like the theme somehow downgrades their quality when they are shown in the hero section…?

    Also, I wanted to use the Featured Services section, but the mouse-over highlight function lights them up in a white box…which kind of clashes with the darker theme I’ve come up with anyway, but most importantly washes out the white text. I had set the white text as a necessity in the Colors section – but I can’t see anywhere to change what that mouse-over highlight color is for that section.

Viewing 15 replies - 1 through 15 (of 18 total)
  • Oh, sorry, one other thing I just remembered…in the header image section, there is what appears to be an option to have the theme randomly select a header image from all the ones you’ve uploaded…but selecting that option winds up using no image at all for the header.

    Theme Author uxl

    (@uxl)

    The theme does not downgrade the photo quality, but depending on your screen resolution you may be seeing your photos scaled up so a little bit of pixelation will be seen if your screen is for example 1920×1080 and your photos are 1024×512, which is why we recommend a minimum image size of 1600×900.

    The second point; for the mouse-over, change this CSS (in Additional CSS or a child theme)

    .featured-post:hover {
        background: #f9f9f9;
    }

    changing the #f9f9f9 variable to a color of your choosing.

    Theme Author uxl

    (@uxl)

    re: randomized header image. This is now fixed in the latest version of the Exoplanet theme (1.5.7)

    The update should be live in the repository very soon.

    I’ll try that new version, and that CSS bit…

    But the photos are bigger than my monitor size. I have a 1920×1080 monitor, and the photos are cut down from their original high-res size to 2000×1000.

    Look at http://www.thunderridgemc.org and see the hero photos as they go by – they’re all slightly out of focus. Then compare them to the actual photos on disk there, and the difference is obvious. Whether or not the darkening layer is there…and I can’t turn that off because then the white text overlays wouldn’t be readable, but it is the same either way.

    http://www.thunderridgemc.org/wp-content/uploads/2017/01/trophies_2.jpg

    http://www.thunderridgemc.org/wp-content/uploads/2017/01/nathan_2.jpg

    http://www.thunderridgemc.org/wp-content/uploads/2017/01/winners.jpg

    Verified that the CSS and new version for headers work 🙂

    Theme Author uxl

    (@uxl)

    The images you linked to above are not the same res as the ones you are using for the hero/slider.

    These are the images you have in the hero which are all 1024×512
    http://www.thunderridgemc.org/wp-content/uploads/2017/01/trophies_2-1024×512.jpg
    http://www.thunderridgemc.org/wp-content/uploads/2017/01/nathan_2-1024×512.jpg
    http://www.thunderridgemc.org/wp-content/uploads/2017/01/winners-1024×512.jpg

    The theme does not crop them down to this size. Have you selected the ‘large’ size instead of original size in the media area perhaps?

    All of the pages are using the original 2000×1000 photos as the Featured Image – and there’s not any options there to change the size of the Featured Image.

    Nor are there options to change it in your Customize options…or in the WP Media options, or anywhere else that I can see.

    So…at what point, where, and why, would those lower-res versions have been inserted in there? I don’t see any reference anywhere that can explain that.

    Theme Author uxl

    (@uxl)

    It is not really possible for me to know what is causing this issue without admin access to your site.

    I cannot answer as to what possible effects the ‘photo gallery’ and ‘wp lightbox’ plugins (and any other plugins) you have installed on the site may or may not have.

    What I do know is that it is not the theme, as there is nothing in the theme which would do this.

    What happens when you disable the plugins I mention above and re-upload the large images as the featured image for those three pages?

    Moderator Jan Dembowski

    (@jdembowski)

    Brute Squad and Volunteer Moderator

    It is not really possible for me to know what is causing this issue without admin access to your site.

    Sure it is.

    There are many ways to get information you need and accessing the user’s site is not one of them. That’s going too far.

    You get the idea.

    Volunteer support is not easy. But these forums need to a safe place for all users, experienced or new. Accessing their system that way is a short cut that will get you into real trouble in these forums.

    Theme Author uxl

    (@uxl)

    OK, fair point.

    I wasn’t asking to be granted admin access, and it wasn’t my intention for the OP (or anyone else) to be under the impression that I was asking for that.

    I communicated it in the wrong way for which I apologize.

    I’m fairly new to providing support, so I will take on board everything you said and learn from it going forward.

    Thanks

    Moderator Jan Dembowski

    (@jdembowski)

    Brute Squad and Volunteer Moderator

    Thanks for clarifying and I just wanted to be sure. Support is not easy. 😉

    Let’s go back to this part.

    What happens when you disable the plugins I mention above and re-upload the large images as the featured image for those three pages?

    And see what the user says after that.

    Well, I gave that a shot…

    To be sure, first I went and deleted those images from the media library. Then I deactivated those two plugins, and re-uploaded the images.

    Re-set them as the featured images on those pages…still the same thing – when I look at the page source, they’re all referenced like ‘http://www.thunderridgemc.org/wp-content/uploads/2017/01/trophies_2-1024×512.jpg’.

    So I’m still at a loss as to what is cutting them into 1024×512 sizes, and then assigning that cut-down version to the hero image.

    Oddly enough, I’ve discovered that if you don’t have a featured image on the pages for the hero section, and just let it default to the one image you can set in customization, the photo shows up perfectly – it’s not using a resized version.

    So, for whatever reason, there’s a different process occurring between what happens with the default hero image specified in the customization, and what happens with the featured image on a page that’s added to the hero section…

    …and just for giggles I decided to do the same thing with all plugins disabled, with the exception of SiteOrigin Page Builder – pretty much all my pages are built with Page Builder, and I was afraid I’d corrupt them by editing them with that disabled.

    Still got the same issue.

    System Info:

    // Generated by the Send System Info Plugin //

    Multisite: No

    SITE_URL: http://www.thunderridgemc.org
    HOME_URL: http://www.thunderridgemc.org

    WordPress Version: 4.7.2
    Permalink Structure: /%postname%/
    Active Theme: Exoplanet 1.5.7

    Registered Post Stati: publish, future, draft, pending, private, trash, auto-draft, inherit

    Platform: Windows
    Browser Name: Chrome
    Browser Version: 55.0.2883.87
    User Agent String: Mozilla/5.0 (Windows NT 10.0; WO
    W64) AppleWebKit/537.36 (KHTML,
    like Gecko) Chrome/55.0.2883.87
    Safari/537.36

    PHP Version: 5.6.29
    MySQL Version: 5.6.25-log
    Web Server Info: Apache

    WordPress Memory Limit: 40MB
    PHP Safe Mode: No
    PHP Memory Limit: 256M
    PHP Upload Max Size: 64M
    PHP Post Max Size: 65M
    PHP Upload Max Filesize: 64M
    PHP Time Limit: 30
    PHP Max Input Vars: 1000
    PHP Arg Separator: &
    PHP Allow URL File Open: Yes
    WP_DEBUG: Disabled

    WP Table Prefix: Length: 10 Status: Acceptable

    Show On Front: page
    Page On Front: Home (#29)
    Page For Posts: News (#31)

    WP Remote Post: wp_remote_post() works

    Session: Disabled
    Session Name: PHPSESSID
    Cookie Path: /
    Save Path: /tmp
    Use Cookies: On
    Use Only Cookies: On

    DISPLAY ERRORS: On (1)
    FSOCKOPEN: Your server supports fsockopen.
    cURL: Your server supports cURL.
    SOAP Client: Your server has the SOAP Client enabled.
    SUHOSIN: Your server does not have SUHOSIN installed.

    ACTIVE PLUGINS:

    Embed Any Document: 2.2.5
    Form Maker: 1.10.5
    Official StatCounter Plugin: 2.0.1
    Page Builder by SiteOrigin: 2.4.21
    Photo Gallery: 1.3.27
    Postman SMTP: 1.7.2
    Send System Info: 1.2
    SiteOrigin Widgets Bundle: 1.7.2
    Super RSS Reader: 2.5
    UpdraftPlus – Backup/Restore: 1.12.32
    Wordfence Security: 6.3.0
    WP Edit: 4.0
    WP Lightbox 2: 3.0.6.2
    Yoast SEO: 4.1

    I also did the WP_DEBUG thing…turned that on and performed the tasks of deleting one of those photos, re-uploading it, and going back to that page to re-add the photo as the featured image – same behavior in terms of using the downsized image.

    The log file only contains 3 error messages…apparently WP really doesn’t like the RSS reader plugin I use – this error is in there a LOT:

    [30-Jan-2017 17:07:44 UTC] PHP Notice: The called constructor method for WP_Widget in super_rss_reader_widget is deprecated since version 4.3.0! Use

    __construct()

    instead. in /home/trmc/thunderridgemc.org/wp-includes/functions.php on line 3891

    Then there’s these 2 bits:

    [30-Jan-2017 17:07:44 UTC] PHP Warning: Cannot modify header information – headers already sent by (output started at /home/trmc/thunderridgemc.org/wp-includes/functions.php:3891) in /home/trmc/thunderridgemc.org/wp-admin/post.php on line 197

    [30-Jan-2017 17:07:44 UTC] PHP Warning: Cannot modify header information – headers already sent by (output started at /home/trmc/thunderridgemc.org/wp-includes/functions.php:3891) in /home/trmc/thunderridgemc.org/wp-includes/pluggable.php on line 1179

    That’s all that was in there. And naturally if it was a problem caused by the RSS reader then things would have worked when I had it (and everything else) turned off. Not sure what the bits about header information are about…

    • This reply was modified 1 year, 9 months ago by  Wootie.
Viewing 15 replies - 1 through 15 (of 18 total)
  • The topic ‘Couple questions – hero images and featured services’ is closed to new replies.