Support » Plugin: Safari Push » Couple of Issues

  • Resolved azchipka


    Ok so I have a couple of issues going on. First of all I think I have everything configured correctly but I am encountering two issues:

    1. 1 When I access the push server page directly I get one of two things displayed. The first is a on going loader of Requesting Permission but it never actually prompts for the permission to be obtained, or I get a notification that says I have denied permission and when I click I changed my mind it just refreshes to the same thing.

    2. From the plugin installation screen at the bottom of the page I have an error that says:

    Warning: file() [function.file]: php_network_getaddresses: getaddrinfo failed: No address associated with hostname in /home/azchipka/public_html/wp-content/plugins/safari-push/safari-push.php on line 342

    Warning: file( [function.file]: failed to open stream: php_network_getaddresses: getaddrinfo failed: No address associated with hostname in /home/azchipka/public_html/wp-content/plugins/safari-push/safari-push.php on line 342

    Warning: array_rand() expects parameter 1 to be array, boolean given in /home/azchipka/public_html/wp-content/plugins/safari-push/safari-push.php on line 343
    Push .

    Plugin version 0.6.2

Viewing 6 replies - 1 through 6 (of 6 total)
  • Also worth noting when I do a test push it just directs my browser to the root of the /v1/push directory on the push server.

    Site with plugin:
    Site Running Push Services:

    Re-setup absolutely everything. Issue number 2 has been resolved. But issue #1 has not.

    It is worth noting I have tested the cert and key files on apples production server and they will make and hold a connection through telnet.

    Apple Error Console is showing an error on live 8 of the bootstrap.min.js file

    Error is TypeError: ‘undefined’ is not a function (evaluating ‘a’)

    I also enabled the error display on the index page as you suggested to andrebazaglia and I am getting the following error there: Undefined offset: 1 in /home/azchipka/public_html/tchpush/index.php on line 33

    which is reference to :
    $function = $path[1];

    Doing a test push still results in seeing the directory root of the /v1/push folder

    Kinda playing the trial and error game at this point. Thinking this problem is related to the certificate since that is such an annoying process in this whole thing.

    Referencing the thread with andrebazaglia; I ran the command openssl s_client -connect -CAfile apns-cert.pem which generated the following error: verify error:num=20:unable to get local issuer certificate
    verify return:0

    The big problem I am encountering here is that your directions say to use: openssl x509 -in website_aps_production.cer -inform der -out apns-cert.pem -nodes -clcerts to which I am being told by terminal -nodes is an unknown option.

    Using the directions referenced from your site for certificate creation found here the certs make and pass the test presented and hold the connection to the server.

    Also when I use the testing code provided by apple openssl s_client -connect -cert tch.pem -debug -showcerts -CAfile tchpushercert.pem the connection reports fine with no errors.

    Plugin Author macgamer


    You have an invalid SSL certificate for

    You’ll probably need to resolve that first.

    As for the pem file, that is only required for actually sending a notification. If you are not getting the prompt to subscribe, then it’s likely due to your push service setup being wrong somewhere.

    See “common issues” at

    the ssl certificate was self signed. Installed a new signed one but for reference purposes according to apple verified or self signed doesn’t matter.

    Either way that didn’t have anything to do with the issue.

    Also already confirmed everything from the “common issues” wasn’t that. Any other ideas

Viewing 6 replies - 1 through 6 (of 6 total)
  • The topic ‘Couple of Issues’ is closed to new replies.