Support » Plugin: Counterize » Counterize ne compte plus les visites

  • Bonjour, je profite du fait que l’auteur du plugin est francophone pour écrire un message en français. I’m sorry for english speaking users but as I speak french like the author of the plugin, we’ll discuss in French here.

    Depuis le 24-11-2013, je pense que c’est suite à des mises à d’un ou plusieurs plugins, le plugin Counterize ne compte plus les passages des visiteurs, qu’ils soient humains ou robots.

    Ce que j’ai essayé :
    – Afficher les erreurs : aucune ne semble directement propre au plugin
    – Rafraîchir la liste des user-agents : Aucun effet.
    – Vider la base de données via les outils du plugin : Aucun effet.
    – Ajouter une entrée manuellement par requête SQL : Ca fonctionne et le plugin affiche bien ma nouvelle entrée
    – Désactiver le plugin, afficher plusieurs pages du blog, réactiver le plugin, afficher plusieurs pages du blog : Aucun changement…

    Que faire ?

    In english My plugin simply doesn’t count anymore my visits, no matter if they’re from bots or humans. I tried numerous things except modify the plugin by myself, nothing has worked. What can I do?

Viewing 3 replies - 1 through 3 (of 3 total)
  • please post in English or possibly post in

    k, sorry in advance, it’s going to be engrish more than english 😡

    Since the 24th november, my Counterize plugin doesn’t work : it doesn’t count anymore the visit for both bots and humans. I think it’s because of some plugin’s updates, but when I turn on the error’s display, it doesn’t show anything related to Counterize.

    What I tried:
    – Show the errors: as explained above, nothing seems to be linked with Counterize
    – Refresh user-agent list: Nothing has changed
    – Flush the database with the plugin’s tools: Nothing changed too.
    – Add an entry manually with a SQL query : It works, Counterize shows my new entry.
    – Deactivate the plugin, go on the blog and browse some pages, reactivate and rebrowse : Absolutely none new entry.

    What can I do?

    I found the solution. I think it’s because my hoster has changed something with Apache, the variable $_SERVER[‘REMOTE_ADDR’] which is used for getting the IP of the visitor sent always “” which is in exclusion list.

    I had to use $_SERVER[‘HTTP_X_FORWARDED_FOR’] for getting the real IP.

    So, in counterize.php, from around the line 1250, I changed this :

    if( isset( $_SERVER['REMOTE_ADDR'] ) )
        $remoteaddr = apply_filters( 'counterize_server_remote_addr', $_SERVER['REMOTE_ADDR'] );

    to this :

    if( isset( $_SERVER['REMOTE_ADDR'] ) )
        if(isset($_SERVER['HTTP_X_FORWARDED_FOR'])) {
            // Fix
            $remoteaddr = apply_filters( 'counterize_server_remote_addr', $_SERVER['HTTP_X_FORWARDED_FOR'] );
        else {
            $remoteaddr = apply_filters( 'counterize_server_remote_addr', $_SERVER['REMOTE_ADDR'] );
        /*echo('<pre style="visibility: hidden;">');

    It now works fine, but idk if this is viable.

Viewing 3 replies - 1 through 3 (of 3 total)
  • The topic ‘Counterize ne compte plus les visites’ is closed to new replies.