Support » Plugin: Jellyfish Counter Widget » Counter is not counting, always stays near the same number.. cache problem??

  • Resolved Pharmax

    (@pharmax)


    Hello,

    We use WordPress 4.2.4 with Jellyfish Counter Version 1.4.4

    For our page: http://bit.ly/1Un4vhq

    We inserted this Shortcode in the page content:

    [jellyfish_counter digits=5 tick_multiplier=’1′ start=’7779′ interval=3255 digit_height=111 digit_width=80 digit_padding=20 flat=true alignment=’center’ digit_style=countership timestamp=”HH:HH:HH”]

    We want the counter to add +1 every 54 minutes (3255 seconds =
    54.25 minutes) but the counter is not counting. What is wrong? I suspect our cache plugins?

    – WP SuperCache
    – Autoptimize (CSS)

    Please tell us how to fix it, thank you.

    https://wordpress.org/plugins/jellyfish-counter-widget/

Viewing 8 replies - 1 through 8 (of 8 total)
  • hi pharmax;
    just for your information; you can disable autoptimize on a per-request basis by adding ?ao_noptimize=1 to the URL. that way you can immediately see if AO is the culprit.

    frank

    Interesting trick, however I am not sure the CSS is the problem (we only use Autoptimize for CSS purpose).

    Thanks for your help anyway!

    Plugin Author Strawberry Jellyfish

    (@toxictoad)

    It’s not a caching issue, a counter is only aware of when it started and when now is and calculates the current value accordingly. That is why the continuous type of counter must have a timestamp.

    Your problem is in your shorcode:

    timestamp="HH:HH:HH"

    is not a valid timestamp, the counter can’t do much without knowing when it should have started. You need a timestamp with a date time in a format like YYYY-MM-DD H:MM:SS for example:

    timestamp = '2014-09-28 9:20:21'

    Thank you for fast answer, you are awesome.

    So I added your code:

    [jellyfish_counter digits=5 tick_multiplier=’1′ start=’7784′ interval=3255 digit_height=111 digit_width=80 digit_padding=20 flat=true alignment=’center’ digit_style=countership timestamp=”2014-09-28 9:20:21″]

    However now it only has 5 zeros? 00000

    How to make it around 7800 with +1 adding every 55 minutes?

    Thank you Strawberry Jellyfish.

    edit: I am setting back the old code so the customers can see 77xx orders until you can help us fixing the issue.

    Thanks,

    Plugin Author Strawberry Jellyfish

    (@toxictoad)

    That was just an example timestamp, you should change that to what you actually need.

    If you use the current date and time with a start of 7784 you should get what you are after.

    If the timestamp is in the past it will calculate the counter value from how many intervals have passed since the timestamp, so you could also make the timestamp 7784 intervals ago (7784 * 3255) seconds and the start value of 0 and you’d get the same result.

    Likewise if the timestamp is in the future, the counter will stay at the start value until it passes the timestamp.

    I suspect the 00000 you saw was just the end of a very large number, the other digits hidden because you are only showing 5

    Hope all that makes sense

    Thank you for your awesome support!

    Hey wanted exactly what pharmax asked for with a slightly different parameters.
    I read the admin answers but was getting confused with time stamp future and past.
    Actually i want to start my counter from 15010 and every 24 hrs i want to increment it by 2.How can i do this. I did like this but can only see 000000.
    Please help thanks.

    [jellyfish_counter digits=’6′ tick_multiplier=’2′ start=’15010′ interval=’86400′ timestamp=’2015-09-2 12:10:21′]

    Plugin Author Strawberry Jellyfish

    (@toxictoad)

    Sorry ammar7, I missed your question here.

    If you still need to know, try adding a large ending value:

    [jellyfish_counter digits=6 tick_multiplier=2 start=15010 end=999999 interval=86400 timestamp='2015-09-02 12:10:21']

Viewing 8 replies - 1 through 8 (of 8 total)
  • The topic ‘Counter is not counting, always stays near the same number.. cache problem??’ is closed to new replies.