Support » Localhost Installs » Countable in C:\xampp\htdocs\test site\wp-admin\includes\template.php line 1448

  • hi

    I received a warning on the permalink setting page after a partial success of copy live website to localhost. All the respective pages have no display of images instead different images_nos like IMG_2697.jpg icons in its place instead.

    I used WP DB Migrate plugin for the transfer.

    Could someone help?

Viewing 4 replies - 1 through 4 (of 4 total)
  • Moderator Jose Castaneda

    (@jcastaneda)

    THEME COFFEE MONKEY

    Are there any active plugins?

    What theme are you using?

    Hi

    I’m using deepfocus 5.1.3 and the active plugins are column shortcodes 0.6.6, compact audio player1.9.6, duplicator 0.5.30 wordpress https 3.3.6

    The warning in permalink setting :
    Warning: count(): Parameter must be an array or an object that implements Countable in C:\xampp\htdocs\test site\wp-admin\includes\template.php on line 1448

    PHP always maintains two active branches. The older of the two is called the “stable” branch. There is no name for the newer active branch, though based on history it should be called the “unstable” branch. 🙂 The newest version of the “stable” branch is almost always the best version of PHP to use on production servers.

    The older active branch is always as secure as the newer active branch. In fact it’s oftentimes more secure. (This is currently true when comparing PHP 7.1.20 to 7.2.8, particularly if Zend OPcache is installed.)

    Right now the active “stable” branch of PHP is 7.1.x. The error you are receiving is specific to the 7.2.x branch. You can fix your problem by reverting to PHP 7.1.x, by waiting until WordPress adds code to deal with the changes to the countable interface in PHP 7.2.x, or by finding and disabling whatever plugin/theme is causing the countable error to be thrown from within WordPress.

    Reverting to PHP 7.1.x is IMO the safest and smartest option, and it’s probably the fastest as well.

    Moderator Jose Castaneda

    (@jcastaneda)

    THEME COFFEE MONKEY

    active plugins are column shortcodes 0.6.6, compact audio player1.9.6, duplicator 0.5.30 wordpress https 3.3.6

    Have you tried deactivating any of those plugins to see if that removes that notice?

Viewing 4 replies - 1 through 4 (of 4 total)
  • You must be logged in to reply to this topic.