Support » Plugin: Cloudflare » count(): Parameter must be an array in Hooks.php on line 133

  • Hi,

    I’ve been getting (a lot of) the following warning in my php error log. Is that something you can fix?

    [18-Jul-2018 06:27:18 UTC] PHP Warning: count(): Parameter must be an array or an object that implements Countable in /home/nginx/domains/{…}/public/wp-content/plugins/cloudflare/src/WordPress/Hooks.php on line 133

    Thanks & kind regards,
    Hans

Viewing 4 replies - 1 through 4 (of 4 total)
  • I have this too.

    Warning: count(): Parameter must be an array or an object that implements Countable in /wp-content/plugins/cloudflare/src/WordPress/Hooks.php on line 133

    New since upgrading from php 7.0 to php 7.2.6

    Running WP version 4.9.7, cloudflare Version 3.3.2

    • This reply was modified 1 year, 4 months ago by aaron843.

    I am having same error as well using php 7.2.6 running cloudflare version 3.3.2

    
    [13-Aug-2018 07:30:32 UTC] PHP Warning:  count(): Parameter must be an array or an object that implements Countable in /home/{...}/releases/128/site/web/app/plugins/cloudflare/src/WordPress/Hooks.php on line 133
    

    use empty() instead of count for php 7.2 compatibility

    I wonder if this plugin is still being supported. 9 months since an update and no response here. I wonder if we should contact Cloudflare directly, but this is the proper place to request WP plugin support.

Viewing 4 replies - 1 through 4 (of 4 total)
  • The topic ‘count(): Parameter must be an array in Hooks.php on line 133’ is closed to new replies.