Support » Plugin: Easy Watermark » Couldn’t remove all watermarks because of an error

  • I messed up the watermarks, so I needed to remove them. The removal process worked until it hit an error with an image file, then it refused to continue. I’m having to restore the original files manually from the plugin’s back-up directory, which is not fun.

    It would be better if the plugin skipped over the file causing an error and continued with the rest, rather than just stop.

    • This topic was modified 6 months, 2 weeks ago by . Reason: Added suggestion for improvement
Viewing 3 replies - 1 through 3 (of 3 total)
  • Plugin Author Kuba Mikita

    (@kubitomakita)

    Sorry it caused the problem. Any chance you know the exact error it throw? This should be definitely populated to the website error_log.

    Thread Starter pandammonium

    (@pandammonium)

    I’m afraid not. The error message displayed on the admin web pages was vague, and I don’t have error logging switched on.

    I think after adding the watermarks, I used the Regenerate Thumbnails Advanced plugin, then I tried to restore the images using Easy Watermarks. After that, some – but not all – of the images that produced errors were missing from my uploads/ folder. Luckily, they were in the ew-backup/ folder, so I used the Enable Media Replace plugin to put them back (and to replace the images that Easy Watermark wouldn’t).

    I’m sorry I can’t be more helpful, but I do appreciate your desire to find out what happened. Thank you

    Plugin Author Kuba Mikita

    (@kubitomakita)

    Got it, thank you for the hint! We’ll investigate this scenario more

Viewing 3 replies - 1 through 3 (of 3 total)
  • The topic ‘Couldn’t remove all watermarks because of an error’ is closed to new replies.