Support » Developing with WordPress » Couldn’t generate POT file

Viewing 3 replies - 1 through 3 (of 3 total)
  • try this: php tools/i18n/makepot.php wp-plugin ./wpcontent/plugins/transcent-coupon/languges/transcent-coupon.pot

    Thread Starter tjsherlock

    (@tjsherlock)

    Thanks, but no dice.

    I was having the same message. In my case I was pointing at my ‘classes’ sub folder within the plugin. Pointing to the root solved it for me.
    But reading your problem you seem to be pointing at the right folder. So after a bit of digging about I think it’s one of two things. (I’m sure it’s not the first.)
    1, There isn’t a <YOURPLUGIN>.php file in the root of your plugin folder. This shows the same message.
    2, Your missing the * Plugin Name: <YOUR_PLUGIN> line in the comments at the top of the <YOURPLUGIN>.php file. Again, shows the same message. Couldn’t generate POT file!
    Hope that helps. 🙂

Viewing 3 replies - 1 through 3 (of 3 total)
  • The topic ‘Couldn’t generate POT file’ is closed to new replies.