Support » Plugin: LifterLMS » Couldn’t enroll student

  • Resolved chunhoong467

    (@chunhoong467)


    Hi, i have been using lifter lms for quite some time. But recently when i try to enrol a student under a course, i cant find any student info in the enroll column. I have registered the student info in user tab. But when i try to search the student’s email,
    it shows no result found.

    photo 1 link: https://drive.google.com/open?id=11tl7Xbx1q5WtI7Vjnr7FLmTFD9R_ajL_
    photo 2 link: https://drive.google.com/open?id=1wM0z03I4146qBoB8b6a1enrNrqgcVbc6

    Support Code: WordPress
    ——————————————-

    Home Url: https://kinsforthcapital.com
    Site Url: https://kinsforthcapital.com
    Login Url: https://kinsforthcapital.com/wp-login.php
    Version: 5.2.2
    Debug Mode: No
    Debug Log: No
    Debug Display: Yes
    Locale: en_US
    Multisite: No
    Page For Posts: Not Set
    Page On Front: Home (#2) [https://kinsforthcapital.com/]
    Permalink Structure: /%postname%/
    Show On Front: page
    Wp Cron: Yes

    Settings
    ——————————————-

    Version: 3.33.0
    Db Version: 3.33.0
    Course Catalog:(#1078) []
    Membership Catalog: Not Set
    Student Dashboard: Member Dashboard (#1085) [https://kinsforthcapital.com/member/]
    Checkout Page: Not Set
    Course Catalog Per Page: 9
    Course Catalog Sorting: menu_order,ASC
    Membership Catalog Per Page: 9
    Membership Catalog Sorting: menu_order
    Site Membership: Not Set
    Courses Endpoint: my-courses
    Edit Endpoint: edit-account
    Lost Password Endpoint: lost-password
    Vouchers Endpoint: redeem-voucher
    Autogenerate Username: yes
    Password Strength Meter: no
    Minimum Password Strength: strong
    Terms Required: no
    Terms Page: Not Set
    Checkout Names: required
    Checkout Address: hidden
    Checkout Phone: optional
    Checkout Email Confirmation: yes
    Open Registration: no
    Registration Names: required
    Registration Address: optional
    Registration Phone: hidden
    Registration Voucher: optional
    Registration Email Confirmation: no
    Account Names: required
    Account Address: required
    Account Phone: optional
    Account Email Confirmation: yes
    Confirmation Endpoint: confirm-payment
    Force Ssl Checkout: no
    Country: US
    Currency: USD
    Currency Position: left
    Thousand Separator: ,
    Decimal Separator: .
    Decimals: 2
    Trim Zero Decimals: no
    Recurring Payments: yes
    Email From Address: supports@kinsforthcapital.com
    Email From Name: Kinsforth Capital Trading Academy
    Email Footer Text:
    Email Header Image:
    Cert Bg Width: 800
    Cert Bg Height: 616
    Cert Legacy Compat: no

    Gateways
    ——————————————-

    Manual: Enabled
    Manual Logging: no
    Manual Order: 1

    Server
    ——————————————-

    Mysql Version: 5.6.40
    Php Curl: Yes
    Php Default Timezone: UTC
    Php Fsockopen: Yes
    Php Max Input Vars: 3000
    Php Max Upload Size: 128 MB
    Php Memory Limit: 768M
    Php Post Max Size: 128M
    Php Soap: Yes
    Php Suhosin: No
    Php Time Limt: 120
    Php Version: 7.1.30
    Software: Apache
    Wp Memory Limit: 128M

    Browser
    ——————————————-

    HTTP USER AGENT: Mozilla/5.0 (Windows NT 6.3; Win64; x64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/75.0.3770.100 Safari/537.36

    Theme
    ——————————————-

    Name: Astra
    Version: 1.5.5
    Themeuri: https://wpastra.com/
    Authoruri: https://wpastra.com/about/
    Template:
    Child Theme: No
    Llms Support: Yes

    Plugins
    ——————————————-

    Astra Starter Sites: 1.3.14
    Classic Editor: 1.5
    Contact Form 7: 5.1.3
    ConvertKit: 1.8.0
    Duplicate Post: 3.2.2
    Elementor: 2.5.16
    LifterLMS: 3.33.0
    Popup Maker: 1.8.6
    Post Grid by PickPlugins: 2.0.35
    Really Simple SSL: 3.2.2
    SG Optimizer: 5.1.3
    SiteOrigin Widgets Bundle: 1.15.7
    Slick Popup: Contact Form 7 Popup Plugin: 1.7.1

    Integrations
    ——————————————-

    BbPress: No
    BuddyPress: No

    Template Overrides
    ——————————————-

    • This topic was modified 6 months, 3 weeks ago by chunhoong467.
    • This topic was modified 6 months, 3 weeks ago by chunhoong467.

    The page I need help with: [log in to see the link]

Viewing 9 replies - 1 through 9 (of 9 total)
  • Plugin Contributor Saurabh

    (@saurabhshukla)

    @chunhoong467 This could be a result of a js error interfering with the autocomplete functionality. Could you check the javascript console and share any errors that you see? Use the instructions here: https://wordpress.org/support/article/using-your-browser-to-diagnose-javascript-errors/#step-3-diagnosis

    Best

    Hi, i have checked the console and it shows one error.

    Link: https://drive.google.com/file/d/157-X5j86lWSRNtJDJc4T9O99oSRJga2c/view?usp=sharing

    As i read from google, i have turned off all the chrome extensions such as adsblocker, the error did go away after that, however i still couldn’t find and enroll student.

    Please provide me the next step to fix.

    Thanks

    Plugin Support Natalie

    (@nrherron)

    Hi @chunhoong467,

    You may have your visual editor disabled.

    If you go to Users->Your Profile, you will see a checkbox that asks if you want to disable your visual editor. If this box is checked it may be causing the issue. Make sure to enable your visual editor and see if this resolves the issue.

    I hope this helps.

    Let us know if you have further issues and we will continue to help troubleshoot.

    Thanks and take care,

    Hi @nrherron, the box is unchecked at default. Any solutions? Or can i give you the rights to access my website for you to fix it? Thanks

    Plugin Support Natalie

    (@nrherron)

    Hi @chunhoong467,

    We aren’t able to take access information on the forums!

    However, for another solution we’ll want to rule out that it’s not a plugin conflict. You can do this by disabling all the pluigns on your site temporarily and see if this solves the issue. If so, then turn each one back on one by one until the issue returns.

    I have a strong feeling it has something to do with Classic Editor. If you see the problem go away with Classic Editor turned off then it will be something in their settings you will have to look at.

    Let us know if this helps locate the issue and we’ll go from there!

    Thanks and take care,

    @nrherron i have tried to turn off the classic editor plugin, still the same 🙁

    Thanks

    Plugin Support Natalie

    (@nrherron)

    Hi @chunhoong467,

    One other issue I can see is that your PHP is out of date with our System Requirements. In fact, 7.1 is going to be phased out this December and WordPress 5.2 will not let you update plugins that are not on the plugin’s supported PHP so, you will not be able to update LifterLMS to the most recent version.

    There is more information on this here: https://lifterlms.com/docs/minimum-system-requirements-lifterlms/

    You can try to have your host update your PHP to the most recent version and see if this solves the loading issue.

    If the issue persists even on the most recent PHP, let us know and we will continue to help find a solution for you!

    Let us know if you have any further questions!

    Thanks and take care,

    Hi @nrherron Yeap i have updated to 7.2 and even reinstall lifterlms. The problem still persists. Beside enrolling students, even on the membership page i also couldn’t find the courses to link to my membership created. Thanks for the help.

    Plugin Support Natalie

    (@nrherron)

    Hi @chunhoong467,

    I apologize for the delay in response!

    The next troubleshooting step we recommend at this point is turning off all other plugins temporarily to see if the issue is resolved. If it is, then you’ll want to turn the plugins back on one by one until you see it reappear.

    This will help rule out plugin conflicts or what plugin the conflict is coming from.

    Let us know if this helps or if you need further assistance!

    Thanks and take care,

Viewing 9 replies - 1 through 9 (of 9 total)
  • You must be logged in to reply to this topic.