WordPress.org

Forums

Gallery2 Importer
Couldn’t get post ID (7 posts)

  1. Tim Rogers
    Member
    Posted 4 years ago #

    Hi,

    I try to import gallery from wordpress and say this error:

    Importing 13899 total Gallery2 albums and images and 0 comments...
    1. Importing Galerias... Couldn’t get post ID Setting gallery page hierarchy...Done! 
Comments
    2.
    3. All done. Have fun!

    Please help!

    Thanks!

  2. Rand HOPPE
    Member
    Posted 3 years ago #

    I had this result, as well.

    Importing 3792 total Gallery2 albums and images and 1 comments...

    Importing Kirby Museum Gallery... Couldn’t get post ID
    Setting gallery page hierarchy...Done!

    Comments

    Importing amazing!... Couldn’t get comment ID
    All done. Have fun!

    :(

  3. Rand HOPPE
    Member
    Posted 3 years ago #

    Installed 3.1.4, and turned on debug, got a bunch of these:

    Warning: mysql_real_escape_string(): 14 is not a valid MySQL-Link resource in /foo/wp-includes/wp-db.php on line 792

    Warning: mysql_error(): 14 is not a valid MySQL-Link resource in /foo/wp-includes/wp-db.php on line 1101

    Warning: mysql_affected_rows(): 14 is not a valid MySQL-Link resource in /foo/wp-includes/wp-db.php on line 1107

    in the first section.

    Then in the comments section, these showed up:

    Notice: Undefined index: 1432 in /foo/wp-content/plugins/gallery2-importer/gallery2-importer.php on line 339

    Notice: Trying to get property of non-object in /foo/wp-content/plugins/gallery2-importer/gallery2-importer.php on line 342

  4. Rand HOPPE
    Member
    Posted 3 years ago #

    upped the memory limit in both php.ini and in wp-config to 256M

    no change

  5. Rand HOPPE
    Member
    Posted 3 years ago #

    upped the max post size to 256M

    now the response is:

    Import Gallery2
    Are you sure you want to do this?

    Please try again.

    With the Please try again linking back to the form.

  6. Rand HOPPE
    Member
    Posted 3 years ago #

    That last response was due to a bad entry in max post size. I'd set it to 2656M. oops! :)

  7. Rand HOPPE
    Member
    Posted 3 years ago #

    Looks like changing "localhost" to "127.0.0.1" made it work. OMG! :)

Topic Closed

This topic has been closed to new replies.

About this Plugin

  • Gallery2 Importer
  • Frequently Asked Questions
  • Support Threads
  • Reviews

About this Topic