Support » Plugin: WordPress Gallery Plugin - NextGEN Gallery » Could not write to file. Please check filesystem permissions.

  • Resolved Your Web Chick

    (@timelymanner1)


    When I try to upload to my gallery, I receive the error message you see in the title. The file does actually upload, as I can plainly see it in my cPanel file manager, but if I try to load the gallery after uploading the new image, I get an additional error message: “lsolesen pel peljpeginvalidmarkerexception thrown”. If I delete the uploaded image and reload the gallery, everything is fine. All the older images are all there.

    I performed a Google search and based on suggestions through that search, I have tried the following:

    Uploading a different image.
    Uploading a smaller image.
    Upgrading my php to 7.0 (the highest version currently available with my host)
    Ensuring my php memory limit is at least 250MB (it is set to 256)
    Ensuring upload limit is set to 30MB or higher (it is set to 64)
    Deactivating all plugins but NextGen Gallery and trying again (didn’t work)
    Replacing my theme with Twenty Seventeen and trying again (didn’t work)
    Checking file permissions of wp-content folder (set to 755)
    My permalinks are already set to post name

    All that and I am still not able to successfully upload to a gallery and have the gallery load. Could it really be just the difference between PHP 7.0 and 7.2?!?!?!

    The page I need help with: [log in to see the link]

Viewing 15 replies - 1 through 15 (of 18 total)
  • I’m having this exact same issue. Just upgraded PHP to version 7.2 on my host (GoDaddy), but it didn’t resolve the problem. GoDaddy support confirmed there aren’t any permission restrictions that would explain this.

    http://www.libersys.net/public/nextgen_gallery_cannot_upload_images.png

    I’m also having the same issue and tried most of the supposed fixes, but no luck yet. Think I might have updated the plugin the other day. Assuming that’s when things went south.

    Is there an easy way to rollback to the previous version of the plugin?

    Incidentally, I just rolled back to version 3.0.16 and was then able to upload my image. So one of these latest two versions of the plugin must have broken this capability.

    What I also just noticed was those previous attempts to upload my image file ACTUALLY WORKED (I found multiple copies of the image in my target gallery), so apparently it’s just a bogus error message.

    Plugin Support edanzer

    (@edanzer)

    Hey all – just wanted to confirm I’ve seen this. While uploads are obviously working fine for all of us and most users in the latest versions, three reports like this suggests there must be a problem. It’s likely something specific to an environment.

    Are any of you a) still having this problem, and b) willing to give us WordPress and FTP creds to your site to troubleshoot? If so, I’ll ask you to submit a but report, and we’ll have a dev diagnose.

    https://www.imagely.com/ (please put “For Erick” in title)

    Thread Starter Your Web Chick

    (@timelymanner1)

    Thanks, @edanzer. Yes, I just tried it and I am still experiencing the issue. I am willing to grant you access to troubleshoot. As a free plugin user, how do I submit a bug report??

    I am also getting different errors on the front end vs the admin.

    ON the admin side, it’s

    Could not write to file. Please check filesystem permissions. Filename: xxx.png

    on the front end, it’s

    LSOLESEN\PEL\PELJPEGINVALIDMARKEREXCEPTION THROWN
    Invalid marker found at offset 0: 0x89

    File permissions are correct, 0755 and 0644. Folder and file ownership is also correct.

    I’ve found the error is there with either PHP 7.0 or PHP 7.2.

    Even after removing the file that had an issue uploading, the gallery still doesn’t work. Galleries uploaded before WP 5.0 update work fine.

    Update: Apparently, deleting PNG files from that gallery made it work.

    • This reply was modified 2 years, 11 months ago by thehowarde.
    • This reply was modified 2 years, 11 months ago by thehowarde.
    • This reply was modified 2 years, 11 months ago by thehowarde.

    @timelymanner1 were the files you were having trouble with – NOT JPEG files?

    Apparently Imagely is saying that they ONLY support JPG/JPEG files.

    Plugin Support edanzer

    (@edanzer)

    @timelymanner1 – You can sumbit a bug report at:
    https://www.imagely.com/report-bug/

    @thehowarde – NGG support png and gif files as well. That said, I just tested this prior to replying, and I DID manage to duplicate the error above with a gif file. That’s news to us, but I have a dev looking into now that I’ve duplicated.

    Again, prior to this we were unable to duplicate, so I’m glad we can so we can fix it. I’d still love a bug report from someone if someone is willing to give us access to evaluate.

    @edanzer

    I opened a ticket with Imagely on this topic. After several posts with them on the topic, this is the final response.

    Thanks for your quick reply, Howard.
    I have asked the devs and it looks like NextGen wasn’t purposefully developerd to support any other image formats excepting JPEGs and the fact that it has supported PNGs was probably a side effect of using a different version of plupload in one of the previous plugin versions. This being said, I would be happy to mark it as a feature request’s vote.

    Sorry for any inconveniences.
    Mihai

    Plugin Author Imagely

    (@imagely)

    Hi @thehowarde
    We sincerely apologize for the inconvenience.
    It’s an existing problem.

    And @timelymanner1

    We already talked with the dev team today, and they are currently taking a look at this moment. ​They will be working in a patch.

    – Gaby

    Thread Starter Your Web Chick

    (@timelymanner1)

    @thehowarde @edanzer @imagely Thanks to all of you for input/response.

    Indeed, I was trying to upload PNG files when the error occurred. I’ve always been able to use PNGs in the past, so it never occurred to me to try a different file type. Hehe.

    I look forward to further news of the patch. In the meantime, I am uploading JPGs to populate my galleries.

    – Bonny

    Seriously? I have to convert hundreds of PNGs to JPGs to use this plugin?

Viewing 15 replies - 1 through 15 (of 18 total)
  • The topic ‘Could not write to file. Please check filesystem permissions.’ is closed to new replies.