WordPress.org

Ready to get started?Download WordPress

Forums

WP Google Maps
[resolved] Could not save XML file (35 posts)

  1. sneak_chamber
    Member
    Posted 10 months ago #

    WP-Google-Maps has stopped saving the XML file since i updated to the latest version, this has since rendered my maps useless :/

    Has anyone else come across this or offer any solution? I've checked the privileges, and they are all good, the plugin won't even make the XML file :/

    I'm not using any CDN or caching plugins. Any help would be greatly appreciated.

  2. lyan12
    Member
    Posted 10 months ago #

    I have the same problem.
    I cannot create the xml file. If i put an old backup XML file, the markers appear but I still get the error message as it cannot update it

  3. lyan12
    Member
    Posted 10 months ago #

    By the way, not using CDN, I check with simple cache desactivated also.
    authorizations are at 777.

  4. WPGMaps
    Member
    Plugin Author

    Posted 10 months ago #

    Hi Lyan and sneak_chamber
    Thanks for letting us know.

    Please confirm that you have set the CHMOD to either 755 (or 777) for the directory AND it's subfolders and files for wp-content/uploads/wp-google-maps ?

    Kind regards
    Nick

  5. WPGMaps
    Member
    Plugin Author

    Posted 10 months ago #

    If yes, please get in touch with me at nick [@] wpgmaps . com

  6. lyan12
    Member
    Posted 10 months ago #

    Yes they are, I did sent you a mail. Yesterday.
    I really need support on this one.

    During activation it said "header already sent" and unexpected characters created.

    It seem that it has been a recurring problem since 2 weeks by looking at all the comments with markers problem, xml file not writing even if the CHMOD is 777. Have you had time to investigate ?

  7. WPGMaps
    Member
    Plugin Author

    Posted 10 months ago #

    Lyan12, I cant see an email with "Lyan" in it. Plaase just pop me a quick email so I can pick up your email address and do a search.

    We've had issues with the marker files recently due to the fact that we swapped over the marker location from the plugin directory (not best practice) to the uploads folder (apparently best practice). This has caused quite a number of new issues which we are trying to iron out at the moment. It appears that on some hosts, this is a tricky task. We're trying to come up with a more solid approach in the next week or so.

  8. elkiloprieto
    Member
    Posted 10 months ago #

    Hi WPGMaps developer. Great job...

    I have the same issue, even with CHMOD 777 in the wp-google-maps folder...
    What else we have to change to write the xml file?
    Thanks in advanced.

  9. WPGMaps
    Member
    Plugin Author

    Posted 10 months ago #

    Hi elkiloprieto
    Thank you :)

    Please confirm that you did a CHMOD for the directory *and* it's files and subfolders in wp-content/uploads/wp-google-maps ?

    Kind regards
    Nick

  10. elkiloprieto
    Member
    Posted 10 months ago #

    Thanks for reply...

    When I open the Maps settings page the first line says

    Could not save marker XML file (/home/www/web241/html/proyectos/myweb/web/core/wp-content/uploads/wp-google-maps/1markers.xml) for Map ID 1

    I opened the with filezilla the upload folder and changed to 777 the permission.. but no files inside... just one folder, cache (no files inside).. I changed also permission to 777 but the story still the same.

  11. WPGMaps
    Member
    Plugin Author

    Posted 10 months ago #

    Hi
    Please ensure you do the following when changing the CHMOD: http://tinypic.com/r/2vmep34/8 - please confirm?

  12. elkiloprieto
    Member
    Posted 10 months ago #

    I did it that way... but nothing changed
    I like your plugin but this is weird... even removed and installed it again...

  13. WPGMaps
    Member
    Plugin Author

    Posted 10 months ago #

    Very weird indeed.
    Could you please contact me on nick [@] wpgmaps . com so we can debug this further?

  14. elkiloprieto
    Member
    Posted 10 months ago #

    Dont worry, at this developing stage I can deal without these maps, but it is a pity because your plugin is full of options, and now I realised also good support. Thanks for help.

  15. WPGMaps
    Member
    Plugin Author

    Posted 10 months ago #

    Thank you

  16. sneak_chamber
    Member
    Posted 10 months ago #

    Hi,
    It looks like the latest version of the plugin has resolved my issues.

    Many thanks
    Darren

  17. elkiloprieto
    Member
    Posted 10 months ago #

    I know it is solved but let me confirm something...

    I could not write the XML (even with right permissions) because a PHP problem of my hosting provider...

    Now is fine and im using the wp google maps pro version!

    God job!

  18. mokummusic
    Member
    Posted 9 months ago #

    I have this problem too.. It seems the path it tries to write the xml file to is messed up -

    Could not save marker XML file (/home/mokummusic/domains/planamsterdam.com/public_html/domains/planamsterdam.com/public_html/wp-content/uploads/wp-google-maps/1markers.xml) for Map ID 1

    See the bold type

  19. Atkheos
    Member
    Posted 6 months ago #

    Hi,
    I mooved my website to OVH hosting and i faced this problem.
    My solution :

    Instead of
    Marker data XML directory: http://yourdomain.com/wp-content/uploads/wp-google-maps/

    Write :
    Marker data XML directory: www/wp-content/uploads/wp-google-maps/

    And it worked for me.

  20. JessiRue
    Member
    Posted 6 months ago #

    I am having the same XML problem that everyone describes in this forum.... except I can't get any of the solutions listed above to work. AND MY MAP APPEARS TO BE WORKING. But the error still shows up.

    I have changed permissions, tried @atkheos suggestion on changing the directory, updated to the latest version but nothing is working.

    Does anyone have any other suggestions.

    website with error

  21. WPGMaps
    Member
    Plugin Author

    Posted 6 months ago #

    Hi Jessi
    Looks like you got it working? What was the issue?

  22. chriscamplin
    Member
    Posted 5 months ago #

    HI, I'm still experiencing this issue, any idea what I can do?

    Thanks.

  23. engrmostafijur
    Member
    Posted 5 months ago #

    sir,

    I have the same problem.
    I cannot create the xml file. If i put an old backup XML file, the markers appear but I still get the error message as it cannot update it

    Mostafijur

  24. dsburdette
    Member
    Posted 4 months ago #

    FWIW, this setting is set in the "wp_options" table of the database (option name=wpgmza_xml_location). I copied my live development site back down to my local computer and am receiving this error as well.

    Setting your permissions on "wp-content/uploads/wp-google-maps" to 777 is fine and dandy but it will never solve your problem because the plugin doesn't appear to update this database settings if you move your site. I tried deactivating/activating the plugin but to no avail. I suppose I'll manually update the path in the database to solve my problem but that's probably not an ideal solution for a lot of people here.

    To the plugin author, any thoughts?

  25. WPGMaps
    Member
    Plugin Author

    Posted 4 months ago #

    Hi
    The latest version of the basic will now update the MARKER XML DIR and MARKER XML URL when you move your site around. We are now making use of internal shortcodes that point to the uploads dir, content dir and plugin dir - you can choose which you'd like to use.

    Please update your basic (and pro if you have) and you should be able to make use of these shortcodes in the MARKER XML DIR and MARKER XML URL fields in the Maps->Settings page.

  26. dsburdette
    Member
    Posted 4 months ago #

    I updated to Version 6.0.28 just prior to making my last post. Is that the version you are referring to? Any other steps I need to take beside deactivate/activate and chmod 777?

    FWIW, I've been using the following in my theme template for page.php but still experience this issue. At what point does your plugin update that database entry?

    <?php echo do_shortcode('[wpgmza id="1"]'); ?>

  27. WPGMaps
    Member
    Plugin Author

    Posted 4 months ago #

    Please go to Maps->Settings (left menu in wp-admin) and have a look at the "marker xml dir" and "marker xml url" fields.

    Try the following:

    Marker XML DIR
    {uploads_dir}/wp-google-maps/

    Marker XML URL
    {uploads_url}/wp-google-maps/

    That should now change the DIR and URL dynamically for you.

  28. dsburdette
    Member
    Posted 4 months ago #

    That's it, thank you! Fast support too!

  29. WPGMaps
    Member
    Plugin Author

    Posted 4 months ago #

    Glad we could help!

  30. Lacau
    Member
    Posted 4 months ago #

    Hello WPGMaps, am experiencing the same problem for the website: http://www.laboratoire-ramousset.fr/contact/
    It says that it can not find the marker xml directory.
    What should i do?
    What do you mean by {upload_url} and {upload_dir}?
    Thanks

Reply »

You must log in to post.

About this Plugin

About this Topic