• Resolved DeepVoid

    (@alexvannini)


    I can’t no longer receive payments with PayPal, some point to a compatibility issue with a ThemeHigh plugin, but this seems unrelated. I receive this error:

    Could not retrieve order. OrderEndpoint.php:459

    Can you help me?

    I have WooCommerce PayPal Payments ver. 1.9.3 on WooCommerce 6.9.2 and WordPress 6.0.2.

    Thank you for any hint.

Viewing 15 replies - 1 through 15 (of 23 total)
  • Thread Starter DeepVoid

    (@alexvannini)

    Is there a way to downgrade to 1.9.1 version of the plugin, waiting for a fix?

    Plugin Support Syde Niklas

    (@niklasinpsyde)

    Hi @alexvannini,

    The compatibility issue with the Checkout Field Editor plugin was resolved in their latest update 1.7.2.
    If you haven’t updated this plugin, I suggest doing so.

    Previous versions of the PayPal Payments plugin can be downloaded from the bottom of this page: https://wordpress.org/plugins/woocommerce-paypal-payments/advanced/ or here if you are encountering any problems specifically with the latest version.

    There could be multiple different causes for the Could not retrieve order. error, though. It can be caused by plugin conflicts, JavaScript errors on your Checkout page, or outdated browsers.
    If you could share with us a copy of your system report, we may get a better idea about what could be causing the issue for you.
    You can share the system report either here in the forums or privately with us from here: https://paypal.inpsyde.com/docs/request-support/
    Thanks!

    Kind regards,
    Niklas

    Thread Starter DeepVoid

    (@alexvannini)

    How to downgrade? Do I need to disable and delete the latest update? Thank you.

    Plugin Support Syde Niklas

    (@niklasinpsyde)

    @alexvannini You can download the plugin version from the link above and then install it as described here: https://wordpress.org/support/article/managing-plugins/#upload-via-wordpress-admin
    There is no need to disable or delete anything. Just install this version, and WordPress will ask you to confirm the upgrade/downgrade.

    There is also a plugin called WP Rollback that allows you to change any installed plugin version with a few clicks. But changing the version manually doesn’t take much longer.
    I hope this helps!

    Kind regards,
    Niklas

    Could not retrieve order. OrderEndpoint.php:459 Order status changed from Pending payment to Failed.

    ===============================

    We get this alot

    1.9.3 , 6.9.4, Current version: 6.0.2

    sice we updatet to the new paypal checkout plugin we got also a lot of erros.

    Like

    OrderEndpoint.php:459

    or

    Failed to process the payment. Please try again or contact the shop admin. [UNPROCESSABLE_ENTITY] The requested action could not be performed, semantically incorrect, or failed business validation. https://developer.paypal.com/docs/api/orders/v2/#error-CANNOT_MIX_CURRENCIES PayPalGateway.php:502 [UNPROCESSABLE_ENTITY] The requested action could not be performed, semantically incorrect, or failed business validation. https://developer.paypal.com/docs/api/orders/v2/#error-CANNOT_MIX_CURRENCIES OrderEndpoint.php:551

    Hi,

    i also get this error!
    Even after downgrading to 1.9.1

    Please help
    Regards
    Eric Menzel

    Plugin Support Andreas W.

    (@aweissinpsyde)

    Hello,

    It has been quite some time since our last communication, so we will mark this thread as resolved. Please open a new thread if you are still facing issues or have questions that you need us to answer.

    Kind regards,
    Andreas

    last post 14 hrs ago??

    I’ve recently installed PayPal plug-in v1.9.3 and regularly get the error Could not retrieve order. OrderEndpoint.php:459 Order status changed from Pending payment to Failed.

    Hi, still getting this error and i dont think a new thred is needet. Please help me with that.

    Same error here, too. Plugin Version 1.9.4

    Same issue – losing business because of it.

    OrderEndpoint.php:459 Order status changed from Pending payment to Failed.

    Also getting this error on v2.0.0 (WP version 6.1.1). Very frustrating as I’m ready to launch my new site, but it doesn’t look like anyone can pay with PayPal.

Viewing 15 replies - 1 through 15 (of 23 total)
  • The topic ‘Could not retrieve order. OrderEndpoint.php:459’ is closed to new replies.