Support » Plugin: Gravity Forms Constant Contact » Could not load Constant Contact contact lists.

  • I just installed this plugin on a separate website (I posted on another thread, about a similar issue). After filling in my credentials and going to create a feed, I encountered the following error:

    “Warning: array_merge(): Argument #2 is not an array in html/wp-content/plugins/gravity-forms-constant-contact/api/cc_class.php on line 181
    Could not load Constant Contact contact lists.
    Error: “

    https://wordpress.org/plugins/gravity-forms-constant-contact/

Viewing 9 replies - 1 through 9 (of 9 total)
  • Hello!

    Sorry for the delayed response. This could be because your credentials are incorrect or you don’t have any Lists created in Constant Contact.

    If neither work, feel free to keep this thread going. Also check to make sure you are on the latest version of this plugin and Gravity Forms.

    Thanks!

    Thread Starter AustinTBiggs

    (@austintbiggs)

    Nikhil,

    My website is current on all updates and the credentials have been checked about 20 times. Everything on my side is correct.

    There are multiple users on the account, would this break your API?

    Thanks!
    Austin Biggs

    Was this resolved? I’m encountering a similar problem. I don’t see any error message, just “Could not load Constant Contact contact lists.” This is with Gravity Forms *personal* license. Does that matter?

    Hello!

    (It shouldn’t matter what Gravity Forms License you have.)

    I’ve tested with a Constant Contact account with multiple users and it seems like the plugin works just fine.

    There could be a possibility that another plugin could be messing with how the Feeds are setup on Gravity Forms.

    I’ll play around with some configurations to see if anything could be messing with the API, but as of right now, I can’t replicate this.

    Thanks!

    OK thanks. FYI I toggled “No Conflict Mode” on and off in Gravity Forms. That made no difference.

    Hi, a little more info. This warning in the PHP logs:
    PHP Warning: array_merge(): Argument #2 is not an array in /www/wp-content/plugins/gravity-forms-constant-contact/api/cc_class.php on line 181

    Thank you for reporting this. The plugin is undergoing some cleanup right now and hopefully this can be dug into a little bit more to fix the issues.

    I am experiencing this same issue. I have the plugin successfully installed on three other sites, but one of my sites gives me the “Could not load Constant Contact contact lists.” Everything is updated, gforms is in no conflict mode, and I have tried deactivating all other plugins besides gravity forms and this add-on. My constant contact credentials have also been verified. Not sure how to debug.

    Hi guys,
    I also had the same issue and according to this post https://wordpress.org/support/topic/plugin-gravity-forms-constant-contact-add-on-header-errors-after-clicking-lets-go-create-one?replies=4, the reason about this problem is the username for my constantcontact.com account.

    So, I had to create a new username, a little shorter than original username, in constantcontact following these options:
    – Start session in constantcontact.com
    – Choose from top left -> My Account -> My Account option
    – Choose from left box -> Account Users -> Manage Users
    – Create a new user with “Account Manager” role.
    (remember to user a short username)

    After that, go to your WordPress website, setting page of Constant Contact plugin and register the new credentials. With the new username, you can now create feeds between Gravity Forms and ConstantContact.com.

    Good luck guys !

    Johnny Lozada

Viewing 9 replies - 1 through 9 (of 9 total)
  • The topic ‘Could not load Constant Contact contact lists.’ is closed to new replies.