Support » Plugin: WP Super Cache » Could not delete directory

  • When I select the “Delete Cache” option in the adminbar of the current page (where I want the cache deleted), I get a blank page with the following text: “Could not delete directory”.

    Is this a file permission issue? If so, what how do I resolve it?

    Thanks!

    The page I need help with: [log in to see the link]

Viewing 5 replies - 1 through 5 (of 5 total)
  • Plugin Author Donncha O Caoimh

    (@donncha)

    It probably is a permission issue. Have you tried using the debug log? That might tell you which directory it’s trying to delete and you can check yourself.

    Ok, I turned on logging (with a fresh log file) and attempted to delete the page’s cache. Looking at the log file, I’m not completely sure how to tell what’s going on. I can see the following (note, I removed the path to my root):

    17:56:37 126671 /wp-admin/index.php?action=delcachepage&path=%2F8911-2%2F&_wpnonce=0dfdcbdb32 wp_cache_get_cookies_values: /^wp-postpass_|^comment_author_|^wordpress_logged_in_/ Cookie detected: wordpress_logged_in_c136bd3e2b0c87455c219747bd8f05e9

    17:56:37 126671 /wp-admin/index.php?action=delcachepage&path=%2F8911-2%2F&_wpnonce=0dfdcbdb32 wp_cache_get_cookies_values: return: e908ac035a219f80f4981c23d633351a

    17:56:37 126671 /wp-admin/index.php?action=delcachepage&path=%2F8911-2%2F&_wpnonce=0dfdcbdb32 Caching disabled for logged in users on settings page.

    17:56:38 126671 /wp-admin/index.php?action=delcachepage&path=%2F8911-2%2F&_wpnonce=0dfdcbdb32 wp_cache_get_cookies_values: cached: e908ac035a219f80f4981c23d633351a

    17:56:38 126671 /wp-admin/index.php?action=delcachepage&path=%2F8911-2%2F&_wpnonce=0dfdcbdb32 wp_cache_check_mobile: stimpackenergy.com443e908ac035a219f80f4981c23d633351a

    17:56:38 126671 /wp-admin/index.php?action=delcachepage&path=%2F8911-2%2F&_wpnonce=0dfdcbdb32 In WP Cache Phase 2

    17:56:38 126671 /wp-admin/index.php?action=delcachepage&path=%2F8911-2%2F&_wpnonce=0dfdcbdb32 Created mutex lock on filename: […]/stimpackenergy/spe-content/cache/wp_cache_mutex.lock

    17:56:38 126671 /wp-admin/index.php?action=delcachepage&path=%2F8911-2%2F&_wpnonce=0dfdcbdb32 Not caching wp-admin requests.

    Any ideas?

    Thanks!

    Plugin Author Donncha O Caoimh

    (@donncha)

    Nothing there is related to deleting files, if all you see is that permission message, it might be the last entry in the debug log.

    I’m seeing this as well, and it’s almost certainly not a permission issue. I’m investigating further.

    I’ve opened a bug report on GitHub with a candidate fix: https://github.com/Automattic/wp-super-cache/issues/380.

Viewing 5 replies - 1 through 5 (of 5 total)
  • The topic ‘Could not delete directory’ is closed to new replies.