WordPress.org

Support

Support » Plugins and Hacks » UpdraftPlus WordPress Backup Plugin » [Resolved] Could not create uploads zip: code=-2

[Resolved] Could not create uploads zip: code=-2

  • I have been installing this on two websites, and have noticed the same error in each of them. The error is:

    0033.229 (0) ERROR: Zip failure: Could not create uploads zip: code=-2

    What does that error code refer to? There is no caching on these websites, so I have ruled out that, plus I believe that would create a “code=-1” error.

    Let me know if you would like the entire log file, and thanks for your help!

    http://wordpress.org/extend/plugins/updraftplus/

Viewing 11 replies - 1 through 11 (of 11 total)
  • Plugin Author David Anderson

    @davidanderson

    Hi,

    Yes – the whole log file, please. Use pastebin.com to avoid annoying the forum moderators.

    David

    Sure thing, chicken wing.

    http://pastebin.com/gXQ58hxJ

    And thanks for the quick response!

    Plugin Author David Anderson

    @davidanderson

    OK. Early in the log file is this:

    0000.006 () Free space on disk containing Updraft’s temporary directory: 0 Mb

    Therefore I’d guess that the error is ultimately due to no free space in which to create the zip files (before they can then be sent to Amazon).

    David

    Plugin Author David Anderson

    @davidanderson

    Also… if you can update to this version (de-install UpdraftPlus, then install this one – all your configuration will be retained), then it will give a more verbose account of the error:

    http://downloads.wordpress.org/plugin/updraftplus.zip

    So if you think it’s not disk space (and it is curious that it managed to write out 7Mb after reporting that 0Mb was free before the error!), then please try that, re-run, and post the new error log.

    Best wishes,
    David

    Thanks for the response. I believe that the “Free space on disk” is an incorrect statement, because the Themes, Plugins, and db are able to be backed up, just not the Uploads zip. I have installed the plugin as requested, and have put the log onto pastebin here:

    http://pastebin.com/XJreJgK9

    Let me know if you need any more information. Thanks again!

    Plugin Author David Anderson

    @davidanderson

    OK. The more verbose error is:

    PclZip Error: PCLZIP_ERR_READ_OPEN_FAIL (-2) : Unable to open file '/nfs/c07/h04/mnt/112128/domains/blog.dermasparx.com/html/wp-content/uploads/sucuri/debug_log.php_sucuribackup.1349117351' in binary read mode

    UpdraftPlus, running under whatever user your webserver is configured to allow it to run as, does not have permission to read that file. So you need to tweak the file permissions on your webserver to allow it to do so.

    David

    Sweet, I appreciate the in-depth explanation. Is there any way to make the two work in conjunction? To give the UpdraftPlus Backup the permissions to access that file? The file in question is from a security plugin, since we have had a few malicious attacks in the past, so it’s security settings can’t be set lower, for risk of allowing another attack.

    Plugin Author David Anderson

    @davidanderson

    I think you just need to reset your file permissions. What are the current file permissions on that file?

    i.e., on the file /nfs/c07/h04/mnt/112128/domains/blog.dermasparx.com/html/wp-content/uploads/sucuri/debug_log.php_sucuribackup.1349117351, look at the file permissions and see what they are. They’re presently not sufficient for any PHP process (such as UpdraftPlus) on your webserver to be able to read the file. You need to reset them so that they are.

    David

    It appears that the files were set to 000 by the Security plugin, so I am unable to set them as any other file permission type. Is there a way to tell UpdraftPlus Backup to skip over any folders in Uploads that contain such files?

    Plugin Author David Anderson

    @davidanderson

    Hi,

    000 on a file does not prevent you from resetting its permissions. The permission to reset file permissions on a file is taken from the permissions of the directory its in.

    i.e. The permissions of /nfs/c07/h04/mnt/112128/domains/blog.dermasparx.com/html/wp-content/uploads/sucuri/ determine whether you can reset the permissions of /nfs/c07/h04/mnt/112128/domains/blog.dermasparx.com/html/wp-content/uploads/sucuri/debug_log.php_sucuribackup.1349117351

    And hence, to reset permissions, you have to keep going up the tree until you find a point you can do it from.

    UD doesn’t yet have a feature to exclude individual files. We’ll add it to the list!

    David

    I appreciate all of your help, and will mark this as resolved! Thank you guys so much for your quick responses, we will make sure and spread the good word.

Viewing 11 replies - 1 through 11 (of 11 total)
  • The topic ‘[Resolved] Could not create uploads zip: code=-2’ is closed to new replies.
Skip to toolbar