Support » Localhost Installs » Could not create directory – some plugin updates failing

  • I have been developing my WordPress site on a WAMPServer on my laptop for a few months, with only a few problems. In the last few days several (but not all) plugin updates have failed – Specifically IThemes Security, MailPoet Newsletters, TablePress. I can reinstall OK, and their settings are still there.

    With the first two I thought it might be something to do with their having changed name, but not TablePress. At the same time some other plugins (MapPress, Google XML Sitemaps) have updated OK.

    It is possibly not WordPress, but where do I start to look? I am experienced in application development, but not in the more technical details. I cannot see any answers so far that seem to apply to a situation where some updates are OK and others are not.

    I have plenty of space on the disk, and no storage limits that I know of. I presume that permissions are not the problem as it all used to work OK, and I do not know that I have changed anything. I don’t see how it can be Windows path lengths as the folder names you can see below are short.

    Apache is 2.4.4, PHP 5.4.12, MYSQL 5.6.12, WordPress 3.9.

    Any help would be appreciated. Thanks

    The result of the latest update is:

    Update Plugin
    Downloading update from…
    Unpacking the update…
    Installing the latest version…
    Removing the old version of the plugin…
    Could not create directory. C:/wamp/www/wp/wp-content/plugins/tablepress/
    Plugin update failed.
Viewing 3 replies - 1 through 3 (of 3 total)
  • I see no one has responded to your week old query so I’ll give you my take on your problem. I hesitate because I am not using WAMP.

    I think it highly likely to be a permission problem.

    I encounter this problem all the time on a self-hosted Windows server and not just with plugins but also with WordPress upgrades. (My specs are Window Server 2008, PHP 5.3.13 and recently upgraded to 5.4.24, MySQL 5.5.11, 5 websites)

    I have spent countless hours researching the problem and experimenting with no satisfactory conclusion. I have at various times implemented debug code which revealed different errors for different plugins but almost always related to some folder or file that cannot be created or accessed. Sometimes it is a tmp folder that is missing entirely…because permissions are not sufficient for the update program to create the temp folder.

    And if I grant higher permissions on either the wp-content folder or the root folder (if doing a WordPress Upgrade) it all works without any hitches.

    So for example, in my case I have to give the IUSR user (anonymous authentications) not just read, read & execute, list folder contents but both write and modify permission. If an upgdate program on windows wants to create a temp directory, IUSR has to have modify permissions on the relevant folder.

    I give up trying to understand the permissions on windows. As a matter of course I increase the permissions. Do my updates. Then revert the permissions. It also helps in the case of WordPress updates to deactivate plugins before udpating.

    I’ve had similar permission issues on Apache installations but these occur less and less often. Not sure why.

    Will be interested to hear if this helps your case in any way.

    I just wanted to add i had a similar problem with updating WordPress 3.8 to 3.9 on WAMP. The operation kept timing out and after reading this post i found muddg answer to be very helpful.

    I had transferred one of my sites from the “www” directory to another install of WordPress. Everything was working i thought but the update kept timing out.

    After reading the last post i went into the “www” directory, located the website folder and checked the permissions – it was “Read only” and after de-ticking the box and clicking ok the update worked fine.

    I am no expert by far and the advise on the net is invaluable in solving my own problems. I hope this helps someone else.

    Thanks for the comments. As it happens I have not had any further problems in the last couple of weeks. I doubt if mine was a permissions issue as I have not changed any permissions, and it first worked, then did not work for a few days, and now works. Hopefully it was just a temporary glitch that will not come back!

Viewing 3 replies - 1 through 3 (of 3 total)
  • The topic ‘Could not create directory – some plugin updates failing’ is closed to new replies.