Support » Installing WordPress » Could not copy files. Installation failed.

Viewing 15 replies - 16 through 30 (of 46 total)
  • Has anyone figured out yet how to do this?

    Also, I am looking at the list of Working Themes with no Issues from the Themes/Theme Compatability/2.7 page, http://codex.wordpress.org/Themes/Theme_Compatibility/2.7

    My theme which is Aurora is not listed in this list. So, what exactly does this mean?

    Moderator Samuel Wood (Otto)

    (@otto42)

    WordPress.org Admin

    Your theme has nothing to do with the upgrade functionality.

    Thanks HandySolo and Otto42, I greatly appreciate your help.

    @handysolo: SElinux is, indeed, in CentOS but is apparently has to be turned off when Cpanel is installed, so, it was already off.

    @otto42: The suPHP tip seems to have done the trick, excellent advice, cheers.

    I am having same problem with two blogs, all versions 2.7 on two different servers. On one server the automatic upgrade stops after “unpacking”. When checking “automatic upgrade” again, WP says “I have the latest version” (still being 2.7…). On the other server, some “fatal errors” popping up. Sorry but something here is WRONG. First time to happen. Unless there is correction, I simply won’t upgrade. Any thoughts? All explanations and tips do not make sense. Messing around with those permissions is not for everybody and why suddenly now?

    OK, found it. Actually thanks to HandySolo. Solution: deactivate the automatic upgrade, then there is still an “upgrade” under tools. All OK suddenly. Weird. Does it mean this plugin is now no more needed?

    Victory too soon. On one server it’s OK, on the other one:
    Downloading update from http://wordpress.org/wordpress-2.7.1.zip
    Unpacking the core update
    Verifying the unpacked files
    Installing the latest version
    Could not copy file: /vservers/h8986wp/htdocs/wp-blog-header.php
    Installation Failed
    ====
    So… Sorry but all the tips above are either “Chinese” for me or look impossible to do…
    Any “simple” advice?

    Further to the previous entry: when I tried to set the file mentioned to 777 I get “SITE CHMOD command failed”. The server I am using is not “as good” as the other one where the tip did work. Problem is, if I have to ask the service provider to change the setting to 777 which files should I request for them to do manually?

    HandySolo

    Where do I check to see if Auto Upgrade plugin is installed?

    Otto42, My theme may have nothing to do with the upgrade. I didn’t say that it did. I merely asked a question which I am asking again,

    “I am looking at the list of Working Themes with no Issues from the Themes/Theme Compatability/2.7 page, http://codex.wordpress.org/Themes/Theme_Compatibility/2.7

    My theme which is Aurora is not listed in this list. So, what exactly does this mean?”

    Cheers

    Moderator Samuel Wood (Otto)

    (@otto42)

    WordPress.org Admin

    I think the problem is that the question doesn’t make any sense. What do you mean by “what does this mean”?

    Will the theme work? Probably. No way to tell.
    Will the theme support the new 2.7 features? Probably not. No way to tell.

    WordPress didn’t create your theme. It has no control over it. And that page you linked to on the codex is not a comprehensive list by any means. So, your theme not being in there means nothing whatsoever.

    @monk – log into your blog and check the Plugins page.

    @bjprc – just to confirm: Yes, from 2.7 and up you don’t want the “old” WP upgrader plugin anymore.

    There are no plugins installed

    Thanks Otto

    I figured as the page was on wordpress.org that it would be comprehensive. My mistake.

    I thought my question was clear. I was merely asking if installing the update would cause issues with my theme. Not quite sure how to make it any cleare.

    However… question solved. As the auto update continues to fail, I manually updated to 2.7.1. It realy is quite easy (even though the comprehensive backup instructions are quite vague). And guess what?? The theme continues to work just fine.

    Rock on!!!

    Cheers

    Thanks to HandySolo for the comment. I am however still at a loss what to do with the permissions. I am afraid manually updating to 2.7.1 will also bring up the permission problems on that one server. Now unable to change to 777 and not clear what exactly to ask the service provider to change – e.g. what files in which folder… Sorry for my ignorance… weird is, the exact same WP software on another service provider was updated without any problems after disabling the old plugin updater.

    [moderated HandySolo now known as Chris_K]

    Did not get any comments here but after discussing with my hosting service and explaining the permission issue, I got their comment as per below (might be of interest to some). I did the automatic update but I was then puzzled I was asked all login data for FTP to the server. Fortunately I did type in the right stuff (copied what my FTP was using) and the automatic upgrade worked against my expectation. So, solved.
    from the service provider:

    “In an effort to prevent compromises of WordPress blogs we recursively locked all ‘wp-blog-header.php’ files on the blog server. There was a known exploit that allowed writing to that file. I have removed all of the immutable attributes for your files in htdocs and you should now be able to change the permissions as you like.
    http://www.HostMySite.com

Viewing 15 replies - 16 through 30 (of 46 total)
  • The topic ‘Could not copy files. Installation failed.’ is closed to new replies.