Support » Installing WordPress » Could not copy files. Installation failed.

Viewing 15 replies - 1 through 15 (of 46 total)
  • It’s possible there’s a permission issue with your host, and it’s not allowing the ‘unpacking’ so you may have to follow the Upgrading WordPress instructions to upgrade to 2.7.1

    I am the host

    I’m having the same problem – no problem upgrading plugins but no luck with the core, getting the same result as Monk.

    And, yes, I the host too!

    I am getting same error at (2) different web hosters:

    Downloading update from http://wordpress.org/wordpress-2.7.1.zip

    Unpacking the core update

    Fatal error: Cannot redeclare pclziputilpathreduction() (previously declared in /home/ccgreenv/public_html_youth/wp-content/plugins/wordpress-automatic-upgrade/lib/pclzip.lib.php:5421) in /home/ccgreenv/public_html_youth/wp-admin/includes/class-pclzip.php on line 5498

    @dswartze – if upgrading from 2.7, disable the auto upgrade plugin and use the upgrader built-in to 2.7.

    @handysolo — thanks! that did it.

    Just to be clear, I don’t have the Auto Upgrade plugin installed and have de-activated the handful of plugins I do have.

    Would it be possible for someone to list EXACTLY what permissions are required to enable automatic upgrades in 2.7?

    Looking around online, it’s fairly clear that a lot of people are having this problem, clearer instructions would help a lot of people and, more importantly, allow hosts such as myself to empower our users to do more with WordPress.

    To those acting as their own host, look through http://codex.wordpress.org/Core_Update_Host_Compatibility to see if you can see something. Maybe upgrade your PHP.

    Also review past info:
    http://core.trac.wordpress.org/search?q=Unpacking+the+core+update

    I have now deleted all my plugins and 777’d everything, but I keep getting this:

    Downloading update from http://wordpress.org/wordpress-2.7.1.zip

    Unpacking the core update

    Could not copy files

    Installation Failed

    MichaelH, thanks for the suggestions but neither of those paths revealed a solution, I tried everything described, one by one.

    I’m using the current version of PHP5, standard WHM/CPanel setup.

    Server config discussions tend to take us a bit out of scope, but just for grins…

    Are you running SElinux? If so, have you been checking your server logs?

    I’m running CentOS, which is RHE rebadged and the most common distribution of Linux for CPanel.

    One thing I’ve noticed from watching YouTube videos of the upgrade process is that some people, after press the automatic upgrade button, get the same login page that I do, asking for FTP details (hostname, user and password), whereas in this video the upgrade process starts as soon as the button is pressed:

    http://www.youtube.com/watch?v=F2N0q7vwh0U

    Is that how it is meant to be for everyone? Why do some of us have to enter the FTP details?

    I have root access, I can change any permissions I want but I simply don’t know what needs to be changed.

    Does all this have something to do with WP being installed/owned by Apache or some other process that doesn’t have FTP permissions?

    CentOS has SElinux on by default, right? (or used to). Have you tried turning that off to see if anything changes?

    Moderator Samuel Wood (Otto)

    (@otto42)

    WordPress.org Admin

    If you are running your own webserver, then look into installing “suPHP” instead of the normal PHP modules. For RedHat compatible systems, it’s usually as easy as “yum install suphp”.

    suPHP makes the PHP process run as the user who owns the PHP files, meaning that the script has the necessary permissions to update itself directly. No more FTP info required.

    suPHP is pretty much the standard for shared hosting setups, as it ensures that somebody hacking into one website won’t have sufficient permissions to hack into the other sites on that server through the same means (assuming everything is chmodded correctly, of course).

Viewing 15 replies - 1 through 15 (of 46 total)
  • The topic ‘Could not copy files. Installation failed.’ is closed to new replies.