WordPress.org

Support

Support » Installation » “Could not copy file:” WP 2.7.1 Automatic Upgrade

“Could not copy file:” WP 2.7.1 Automatic Upgrade

  • Hi guys. I got prompted to upgrade to 2.7.1 and I choose the automatic route. Once I entered my FTP details I receive an error message stating “Could not copy file: /httpdocs/blog/wp-admin/admin-header.php” “Installation Failed”.

    I have also received the same error message but with references to JS and Gif files.

    I have set my upgrade/core/wordpress folders to 777 but that didn’t resolve the issue.

    Any idea on a possible solution to this problem?

    Cheers,
    Cormac

Viewing 15 replies - 1 through 15 (of 22 total)
  • same problem here! i disabled the automatic upgrade plugin, made sure all the right folders are chmodded to 777 and even tried implementing some weird workaround i came across. all to no avail. 🙁

    I went through this same issue on one blog and what I ended up having to do was chmod each file that was mentioned to 777. So RolloTamasi, in your case you need to set your file permissions for admin-header.php to 777. After doing that you will get another copy error regarding another file and you will need to do the same thing – set the file permissions to 777. It was a very tedious process and there were about 25 files involved. Setting permissions to the directories have no effect.

    Right now I am having problems with another blog upgrading 2.7.1 with automatic upgrade. The process gets stuck at unpacking the core files.

    I have the same problem, “The process gets stuck at unpacking the core files”.

    When trying to upgrade 2.7.0->2.7.1 I get

    Downloading update from http://wordpress.org/wordpress-2.7.1.zip

    Unpacking the core update

    Could not copy file: /wordpress/wp-content/upgrade/core/wordpress/wp-trackback.php

    Installation Failed

    The problem seems to be that the files are uploaded as the ftp user which is different to the apache user. The file permissions are set as 711.

    I thought I has cracked it by setting the FTP server umask to 113:002 (apache and the ftp user are in the same group), but while this seems to correct any permissions on file I upload myself, the files uploaded/unpacked during the upgrade process still have permissions of 711.

    Unfortunately manually setting the permissions on files that are complained about (as suggested by pal0216) doesn’t work because the files are re-uploaded (and so permissions reset) each time I restart the upgrade process.

    Something in the upgrade process to chmod the files (using FTP) as required would probably fix it.

    Sorry it doesn’t solve this, but hopefully it adds some more insight into the problem.

    Rob

    for those who are struggling with this, I discovered that the problem for me was caused by using Pure-ftpd FTP server. I switched to vsfptd and not only do installations (plugins too) work but they install really quickly.

    For my own reasons I still need to run pure-ftpd on port 21 so what I did was configured vsftp on a different port. Here is what I did…

    yum install vsftp
    vim /etc/vsftpd/vsftpd.conf

    Add the following line:
    listen_port=151

    Then when WordPress asks you for your FTP host, enter yourhostname.com:151. I hope this is helpful to others as it was for myself.

    Yeah, I’m using Pure-FTPD, but I’d rather not have to install another FTP server on our server just for this.

    I had the same problem, and it was because the passive option was switched off.
    Try allowing passive connectios.

    Passive is allowed on our server, although restricted to a particular port range to allow it through the firewall.

    Still doesn’t work

    Thanks amandato~ it works for me.
    seems wordpress set the default port as 21.

    You shouldn’t need to change permissions since wordpress is logging in as if you were logging in via FTP.

    All you need to do is rename the folder /wp-content/upgrade to ‘upgrade2’ and then rerun the upgrade automatically link. WP will recreate the upgrade folder and proceed.

    @mrl144: Thanks for the tip, but it didn’t work for me. WP did indeed create a new “upgrade” folder, but I still received the following error message:

    Downloading update from http://wordpress.org/wordpress-2.8.4.zip.
    
    Unpacking the update.
    
    Could not copy files.
    
    Installation Failed

    Renaming the folder doesn’t help for me either: I get the following

    Downloading update from http://wordpress.org/wordpress-2.8.4.zip
    
    Unpacking the core update
    
    Verifying the unpacked files
    
    Installing the latest version
    
    Could not copy file: /wordpress/index.php
    
    Installation Failed

    I think I’ll do a manual upgrade and see if future upgrades are any better.

    I was getting the same error as many mentioned above.
    What solved it for me was the following command
    sudo chown -R www-data:www-data /websites/gramtech/
    This is obviously if you are hosting from a Linux box and /websites/gramtech/ is the location of my wordpress blog.

    Just as an FYI, I found that all the files had the permissions root:webadmin, changing it to www-data:www-data solved the problem as this is the account used by apache which does the actual install.
    I really didn’t like the idea of changing the file permissions to 777

    @gramtech

    That’s sounds like an excellent solution but, on my server, www-data:www-data was not recognized as a user.

    Does Apache use different account names under different distributions of Linux?

    I am using Centos (same as RedHat), with WHM/CPanel installed.

    Hooray!

    I managed to get plugin upgrading working by changing my FTP server from Pure-FTPD to ProFTPD, which the only other option available via the WHM/CPanel dashboard.

Viewing 15 replies - 1 through 15 (of 22 total)
  • The topic ‘“Could not copy file:” WP 2.7.1 Automatic Upgrade’ is closed to new replies.
Skip to toolbar