Support » Fixing WordPress » Could not copy file. Upgrade Fail

  • Resolved James Laws

    (@jameslaws)


    I am getting the much maligned Upgrade fail message:

    Downloading update from http://downloads.wordpress.org/plugin/akismet.2.5.1.zip…

    Unpacking the update…

    Could not copy file

    This happens for every plugin and core upgrade. I’ve tried all the usual things like deleting the upgrade folder and changing permissions.

    I feel silly posting this but I’m at a loss. I am the server admin so I have full access but I’m not sure how to correct this. I also know that I was at one time able to do automatic upgrades but can’t for the life of me think of anything that I’ve changed that would cause this.

    Any guidance would be greatly appreciated.

Viewing 15 replies - 1 through 15 (of 24 total)
  • Could not copy files means a permission issue, I believe.

    Have you upgraded PHP since the last time this works? It could have changed its settings and goobered this.

    Actually, no I haven’t. I’m using PHP Version 5.2.13 and have been for a very long time. I agree that it’s permission issues but not sure what to check at this point.

    Try deleting the folder wp-content/upgrade and recreating it with permissions 777.

    Yeah, I’ve done that. It doesn’t seem to change anything. And to further confirm it’s a file permissions issue, I can’t delete plugins either.

    What are the file ownerships on the plugins folders?

    Has your server upgraded at all? I know cPanel pushed a small OS update out recently that kicked a lot of folks. And IIS too…

    I’m on a VDS and no cPanel. Main user (not root of course) is the owner of the plugins directory. And really all of WordPress.

    VDS = Virtual Dedicated Server? (TLAs are so annoying, at work VDS is Veteran’s Data Services… My brain needs a reboot)

    So it’s jameslaw:jameslaw owning the folders and files?

    What ID does PHP run under?

    Yes, Virtual Dedicated Server and ownership is correct. I think I need a reboot as well. 🙂

    Can’t REALLY hurt.

    Or rather, if it does, there’s your problem 😉

    I’ve also added these to my wp-config…

    define(‘FTP_HOST’, ‘*********’);
    define(‘ftp_user’, ‘*********’);
    define(‘FTP_PASS’, ‘*********’);
    define(‘FTP_SSL’, true);
    define(‘FTP_CONTENT_DIR’, ‘*********’);
    define(‘FTP_PLUGIN_DIR’, ‘*********’);

    First time I’ve used them so not sure if that’s a problem. It’s all the same info I obviously use to sftp to my site normally.

    When trying to WordPress Autoupdate, make sure that you FIRST:

    0. Delete the Upgrade folder completely from your server
    1. Go into your Plugins page
    2. Click the checkbox above all of them to select ALL plugins
    3. From the pulldown, select DEACTIVATE, then OK it
    4. Try the update again – that usually takes care of the errors for me.
    5. Don’t forget to re-enable your plugins as in Steps 1-3

    @jpneok, thanks. I’ve done all that before this thread and still have the problem.

    Also, concerning my comment above about the wp-config, I haven’t actually moved my wp-content or plugins directory but the system doesn’t seem to find them if I don’t include those as well.

    The wp-config stuff shouldn’t matter BUT!

    I haven’t actually moved my wp-content or plugins directory but the system doesn’t seem to find them if I don’t include those as well.

    Now we’re talking turkey!

    This is looking more and more like something got screwy with your server. I mean, WordPress RUNS without you defining those, right? But it won’t upgrade. So the tricks PHP uses to upgrade can’t find them, which could be … Ugh. Brain not functioning fully.

    I want to say a base_dir redirect isn’t working, but that feels WAY out there…

    Have you made ANY server changes since the last time this worked?

    esmi

    (@esmi)

    Forum Moderator

    I might be just muddying the waters here but this is beginning to sound similar to another issue: http://wordpress.org/support/topic/30-upgrade-bug-ftps

    The absolute only thing I changed, and I think (not positive) it has worked since this is I changed my root directory in httpd.conf. However WordPress should still see this as $base = ‘/’; so it shouldn’t effect it in anyway.

    At least I don’t think it should.

Viewing 15 replies - 1 through 15 (of 24 total)
  • The topic ‘Could not copy file. Upgrade Fail’ is closed to new replies.