Could not copy file: /public_html/blog/wp-content/upgrade/wordpress-2.8/wordpres (14 posts)

  1. The Secret Cash Builder
    Posted 7 years ago #

    Please help...

    I already upgraded to 2.8 and I no longer have the visual editior.

    I'm trying to re-update to see if it will fix this as mentioned here: http://wordpress.org/support/topic/278484?replies=21

    I get this message: Could not copy file: /public_html/blog/wp-content/upgrade/wordpress-2.8/wordpress/wp-comments-post.php

    and the re-update fails.

    Any idea why?

  2. SmockLady
    Posted 7 years ago #

    I'm getting the same message although I was upgrading from 2.7.1 a first time. A few plug-ins broke, but I was able to fix those with re-installs or deactivation/reactivation.

  3. Bryan Hoffman
    Posted 7 years ago #

    I got the same message about not being able to copy the wp-comments-post.php file, and here's how I fixed it:

    1. I logged into my server via ftp
    2. Located the upgrade files in wp-content/upgrade
    3. Tried to delete the core directory and all its contents (these, I believe are the upgrade files)
    4. I was denied permission to delete these files (on my own server no less), so I used Terminal (on a mac) to ssh into the server and delete the 'core' directory.
    5. Re-ran the upgrade from within WP, and all was well.

    Hope this helps.

  4. The Secret Cash Builder
    Posted 7 years ago #

    Well I had no problem deleting the file, but when I re-ran the upgrade I got the same error. :(

  5. etomyam
    Posted 7 years ago #

    I'm also having same situation, I successfully upgraded to 2.8 but couldn't upgrade any plugins...the message : Could not copy file /public_html/wp-content/upgrade/my-category-order.2.8/my-category-order/mycategoryorder-de_DE.mo

  6. SmockLady
    Posted 7 years ago #

    fwiw, i reset my upgrade folder file permissions to 777 and i was able to upgrade. got a weird error message right before that popped up and was gone so I was not able to get a screenshot or read it, but i am upgraded successfully now. i think it said something about MSQL. no problems so far, but we'll see how it goes.

  7. Jeff_L
    Posted 7 years ago #

    I downloaded a copy of 2.8 to my local PC. Logged into CPanel, opened file manager and did a copy and paste/replace job of the wp-comments-post.php file. I was then able to upgrade via the WP admin panel auto-upgrade function. Guess the upgrade process checked to see if the latest update date of the wp-comments-post.php was more recent than the auto-upgrade version and, seeing that it was updated on 6-22 the auto-update function didn't even attempt to upload the WP 2.8 version, which I believe has the wp-comments-post.php file dated in May 2009.

    Hope that all makes sense. I, too, am always groping around in the dark when it comes to mucking with code, servers, etc.

  8. pepe-gonzales
    Posted 7 years ago #

    Hi, I have the same problem and found out, that some files in the upgrade/core/wordpress path have an empty file size. If I open the file it is empty. Example: revisions-js.php in upgrade/core/wordpress/wp-admin/js/

    It seems to me that in the process of copying from the temporary folder to upgrade/core/wordpress a different process deletes the content. Maybe a virus protection or so.

    This error happens only at my hoster "hosteurope" but not on my hoster "hoststar".

    Maybe this is a hint to further improvement.

  9. bumblybee
    Posted 7 years ago #

    Hi guys :)
    I too ran into this problem last night.
    After doing all the necessary backups I was prepared to do a manual install but I had a quick thought.

    I first installed WordPress using Fantastico in cPanel. I went back into Fantastico, where it urged me to upgrade, I gave it a shot and it was successful!

    I understand that a lot of you would've installed WP manually and that this step won't work for you but for those who did use the autoinstaller - see what happens?

  10. chrisryall
    Posted 7 years ago #

    Deleting the Core folder in wp-content/upgrade/ worked for me

  11. nextwave
    Posted 7 years ago #

    I was getting the same error on every plugin upgrade.
    My upgrades folder had a file in it- that I couldn't delete.
    I deleted the upgrades folder in wp-content/
    made a new upgrades folder-
    set it to 755
    voila- everything worked.

  12. Stocktrading101
    Posted 6 years ago #

    Deleting the WordPress folder in wp-content/upgrade/ worked as well for me as I too was experiencing the same error.

  13. pp19dd
    Posted 6 years ago #

    For some reason I've never been able to make this upgrade feature work either. Once, I think, it worked flawlessly for me. Every other time- I'd get a nice little error that would go something like:
    Could not copy file: /blah/wp-content/upgrade/wordpress-2.tmp/wordpress/wp-comments-post.php
    I've tried all the standard tricks; recreating wp-content/upgrade and setting permissions, etc. It would be nice to have this upgrader say why exactly it failed (aren't detailed error messages actually helpful?)

    Anyhow, this trick worked for me. I ssh'd in and ran this (totally cheating, I know):

    watch -n0.1 "chmod a+rwx -R /blah/wp-content/upgrade/"

    Then I initiated the upgrade and -- the upgrade actually worked. It seems like the ftp method of uploading forgets, inadvertently resets, or otherwise assumes way too much in ways of permissions.

    DISCLAIMER: don't follow this trick unless you know what you're doing. Seriously. This resets all permissions recursively every 0.1 seconds.

  14. udey
    Posted 6 years ago #

    Hi all,


    I was facing a similar problem while installing themes and was running the latest version of WordPress (Version 2.9.2).

    I tried various themes, all which couldn't get installed or copied.

    So finally, I gave all the rights to the database user.
    Still the problem existed.

    And I was installing the themes from the Dashboard of the WordPress.

    Went to the File Manager in my hosting service provider.
    Gave all the rights to all the folders - which then appears as 777

    Now installed the same theme that gave the error and it got installed and seems all set to go.

    Best Wishes,

Topic Closed

This topic has been closed to new replies.

About this Topic


No tags yet.