Support » Plugin: SG Optimizer » Could not connect to the WordPress Rest API

  • Resolved DougRees

    (@dougrees)


    Hello,

    I am getting the error “Could not connect to the WordPress Rest API” when I go to the SG Optimizer dashboard.

    I have turned off Wordfence, my only security plugin, reviewed the live log in Wordfence, looking for anything being blocked, as described in other posts, with none shown.

    I reviewed the .htaccess file and while not a pro, see nothing that sticks out as blocking this from access.

    I have no other caching plugins and cleared cache from everywhere I could, including two different browsers, with no change.

    I have uninstalled and reinstalled SG Optimizer with no change.

    I see no other clues here or on line and would appreciate any other hints that could be provided.

    The page I need help with: [log in to see the link]

Viewing 5 replies - 1 through 5 (of 5 total)
  • Thread Starter DougRees

    (@dougrees)

    I should have mentioned – it was working fine hours ago.

    I have not installed any other plugins or made any other changes that I am aware of.

    Plugin Author Stanimir Stoyanov

    (@sstoqnov)

    SiteGround Representative

    Hey @dougrees

    The WP Front notification bar plugin adds some CSS to the rest API endpoint, which results in broken JSON response.

    
    <style type="text/css">
        #wpfront-notification-bar 
        {
    

    This is part of the REST API response. From there, we cannot parse the JSON, that contains the plugin settings.

    Regards,
    Stanimir

    Thread Starter DougRees

    (@dougrees)

    Thank you, I never would have found that myself. Inactivating the plugin allows me to see all the settings again and removes the error.

    Hi @dougrees,

    Can you please test the latest version of notification bar plugin?

    Thanks

    Thread Starter DougRees

    (@dougrees)

    Hello @syammohanm,

    Thanks for the update, it does function and is not impacting the SG Optimizer dashboard any longer. Thanks for checking.

    Doug

Viewing 5 replies - 1 through 5 (of 5 total)
  • You must be logged in to reply to this topic.