WordPress.org

Forums

WooCommerce - excelling eCommerce
Could not compile woocommerce.less (3 posts)

  1. emi21
    Member
    Posted 1 year ago #

    Hi,

    I have a compilation issue after upgrading the new Woocommerce version. My WP-admin is no more accessible. What is the solution? I have tried to reinstalled the plugin but I have still the same problem.

    Here is the error message :

    Impossible de compiler woocommerce.less : expected color value: failed at .vertical_gradient( lighten( @secondary, 2 ), @secondary ); /srv/data/web/vhosts/iav.e-marlie.com/htdocs/wp-content/plugins/woocommerce/assets/css/woocommerce.less on line 81

    Thanks for your help !

    https://wordpress.org/plugins/woocommerce/

  2. timscullin
    Member
    Posted 1 year ago #

    I am having a similar issue.
    I uninstall the plugin and it's fixed so if I downgrade I can get it working, but this is annoying:

    Could not compile woocommerce.less: parse error: failed at @subtext: #username; /SITEURL/wp-content/plugins/woocommerce/assets/css/woocommerce-base.less on line 13

    woocommerce-base looks like this, and if I change and save it then try to access the site it just reverts back:

    @primary:       #ad74a2;
    @primarytext:   desaturate(lighten(@primary,50%),18%);
    
    @secondary:     #f7f6f7;
    @secondarytext: desaturate(darken(@secondary,60%),18%);
    
    @highlight:     #85ad74;
    @highlightext:  desaturate(lighten(@highlight,60%),18%);
    
    @contentbg:     #ffffff;
    
    @subtext:       #username;
  3. timscullin
    Member
    Posted 1 year ago #

    ok I figured my issue out, somehow I had accidentally typed the username into the subtext style box:
    http://share.labs.la/image/40191a420c3x

    Turns out this will break the .less

Topic Closed

This topic has been closed to new replies.

About this Plugin

  • WooCommerce - excelling eCommerce
  • Frequently Asked Questions
  • Support Threads
  • Reviews

About this Topic

Tags

No tags yet.