Support » Fixing WordPress » could import from blogger, can’t now… why?

  • To anyone that can help me:

    I installed the WordPress software on my own server a couple of weeks ago and immediately imported my blog from Blogger. It worked fine then – when I had about 41 blogs.

    I have since added blogs to my Blogger acount as I have not switched completely now, and yet when I finally go to import my blogs one more time it won’t import the last 3-4 I have done.

    It worked fine, but now I don’t know what’s happening.

    I attempted the XML file import from a WordPress.com account to no avail – something to do with /uploads permission errors (which I have gone over: 777 to default upload folder wp-content/uploads.)

    I have cleared my information, but it imports no new blogs before asking me to set author. I’m simply at a loss. Obviously I can simply copy paste 3-4 blogs, but I will loose all the comments and posted dates in the process.

    Could someone help here? Please.

Viewing 15 replies - 1 through 15 (of 15 total)
  • It worked fine then – when I had about 41 blogs.

    By “blogs”, do you mean blog posts or separate blogs?

    Blog posts, my bad… who in the world has 41 blogs?

    who in the world has 41 blogs?

    Sploggers. 😉

    Could something have changed (code, settings, content) in your most recent Blogger posts that would keep import from working?

    I have no idea. Since I did the posts that did import fine, I have noticed nothing different – no new code or design or layout or anything.

    I simply, don’t get it… boo.

    Hi,
    I am having a similar problem.

    When I try to import a blog, it acts like it is importing (shows 1 post and 1 comment has come over) and then the “magic button” changes to “Set Authors.”

    When I click Set Authors, there are no authors to choose from and no content has been imported.

    What is going on? I have cleared the info, cleared the cache, and even restarted… but same thing keeps happening.

    Any help would be greatly appreciated!!

    Thanks,
    Stacy

    I’m having the exact same problem, except mine imported 50/92 posts and 50/206 comments and it stopped, and the magic button changed to “set authors”!!

    HELP!!

    HELLO??? Anyone here to help?? :S

    Same problem here… I’m trying to import 1,063 posts from blogspot. It gets to 46 or 50, then the magic button changes to “Set Authors.” At that point, 30/30 comments import, then the process stops.

    I clicked on the Set Authors button, and set the blogger users to the proper wordpress users. But when I went back to continue importing, the magic button still said “Set Authors,” and there was no Restart button. I finally decided to start the entire process again, since wordpress says any entries that had previously been imported would be skipped. But the first 50 posts just doubled up and, again, the process stopped.

    I tried using the xml file import, but that doesn’t do work either.

    Could someone help out with this problem?

    Oh no –
    Five months later and no solution, but I am having that problem too!

    Exactly as described…

    PLEASE – someone, anyone, can this be fixed?

    (I’m self hosting wordpress and am trying to import a Blogger blog of about 650 posts).

    Solution! – (if you’re self hosting)

    Assuming you’re probs are the same as mine, I found a solution in this very forum, here:

    http://wordpress.org/support/topic/200104?replies=16#post-1022178

    Quoting the genius, mercime:

    1. create free account in http://wordpress.com/
    2. Manage > Import > Blogger – don’t be discouraged if it doesn’t work first or second time – just make sure that you have the correct username and password
    3. After you import from Blogger, Manage > XML Export > All and save to computer.
    4. Open self-hosted WordPress and Manage > Import > WordPress. Sometimes, you can get it all imported in one go, other time, need to go through import process more than once.

    Worked great for me, and hope it does for anyone else!

    PS – wordpress forum search is pretty sucky – I had a hard time finding this thread again so I could report my solution…

    tracylee – I tried this solution, but I get this error from Google:

    The page you have requested cannot be displayed. Another site was requesting access to your Google Account, but sent a malformed request. Please contact the site that you were trying to use when you received this message to inform them of the error. A detailed error message follows:

    The site “http://wordpress.com” has not been registered.

    Anyone have any other ideas on this?

    madhatterdesign,

    I receive the same message although a couple of weeks ago I did not.

    Anyone have any ideas?

    Alan

    I still haven’t figured this out. None of the solutions are working. My best guess is that it just can’t be done.

    I have imported from blogger to wp.org via wp.com in the past but now get the same message as above.

    The site “http://wordpress.com” has not been registered.

    Seems like something has changed at the blogger / google end.

    I’ve got plenty of other things to be getting on with so will try again in a week !

Viewing 15 replies - 1 through 15 (of 15 total)
  • The topic ‘could import from blogger, can’t now… why?’ is closed to new replies.