Support » Plugin: Multiple Domain Mapping on Single Site » CORS error… again

  • Hello,

    I love the plugin. It’s great.

    It gives me the well-known error

    has been blocked by CORS policy: No 'Access-Control-Allow-Origin' header is present on the requested resource

    I tried to add the following:

    Header add Access-Control-Allow-Origin "*"
    Header add Access-Control-Allow-Methods: "GET,POST,OPTIONS,DELETE,PUT"

    To my htaccess but the result was… well you see the result if you try to go to herbariumcontravirus.com
    It seems that half of it is resolved. I tried cache clearing reloading cookies etc but I was unable to get it to work.

    Could you please help me out with that?

    The page I need help with: [log in to see the link]

Viewing 2 replies - 1 through 2 (of 2 total)
  • Plugin Author matthias.wagner

    (@matthiaswagner)

    hy,
    i could not see any cors-errors in the console or obvious display errors when visiting that url. could you already resolve your issue?

    Hello,

    No, I was unable to resolve the issue. However, the customer needed to get the website live and I disabled the plugin and used .htaccess to do a 301 redirect to the page. You can see however that the URL of the page is not http://herbariumcontravirus.com. It changes to a relative URL to my original website.

    Right now I’m trying to either figure out how to make the plugin work properly or how to make the htaccess redirect mask the URL. Either solution will work at this point.

Viewing 2 replies - 1 through 2 (of 2 total)
  • You must be logged in to reply to this topic.