Support » Plugin: Comet Cache » Correct Settings for an e-Com Store (Woocommerce)?

  • Resolved Craig

    (@craigrkirkby)


    Hi

    I recommend your plugin to all my clients. Really enjoy it. Thank you.

    I was just wondering what you suggest as the best settings for a e-Com store. (I’m using Woocommerce.)

    My thinking is that adding something like this in the URI Exclusions is the way to go:

    ^/product/**
    ^/my-account/**
    ^/cart/$
    ^/checkout/$

    That is, I don’t want the pages related to the online shop cached, as I’m under the impression that it may affect AJAX buttons, cart totals, etc.

    Am I right/wrong? What would you do for an online store?

    Many thanks!

    • This topic was modified 5 years, 4 months ago by Craig.
Viewing 3 replies - 1 through 3 (of 3 total)
  • @craigrkirkby Comet Cache has integration with WooCommerce so there really isn’t anything you need to do. AJAX requests are actually the only type of dynamic request that is cache-compatible, so you shouldn’t need to worry about those. Comet Cache also includes integration to automatically clear the appropriate cache file(s) if, for example, the order quantity changes and the front-end needs to be updated.

    Any pages that shouldn’t be cached, WooCommerce will set the DONOTCACHEPAGE constant which tells all WordPress caching plugins not to cache that specific page—Comet Cache obeys that standard, so any pages that WooCommerce has deemed not cache-compatible will not be cached.

    In any case, if you’d prefer, you can certainly exclude whatever pages you’d like using the URI Exclusion Patterns you mentioned (those look good to me).

    Thread Starter Craig

    (@craigrkirkby)

    @raamdev

    Thank you for your prompt and thorough reply. Really appreciate it.

    I’ve had a couple of problems with customers unable to proceed to payment with the system saying the stock is not available (when there is stock available).

    I’ve checked everything I can think of to flush out the error. I just wanted to eliminate the caching issue as a reason.

    So, from your reply I take it caching is NOT the reason. If that’s correct, no need to reply (and you’re welcome to close this thread). I will carry on the hunt.

    If it could be the reason, please advise.

    Thanks again.

    • This reply was modified 5 years, 4 months ago by Craig.

    @craigrkirkby It’s still possible that this is a caching issue. We’ve worked to integrate Comet Cache with WooCommerce so that it listens for when the item stock changes, but there are all kinds of reasons that integration might not be working for you, including specific WooCommerce plugins you’re running that Comet Cache isn’t aware of, or a change in the WooCommerce Core plugin that we’re unaware of.

    The first step to troubleshooting is to reproduce the problem. If you can reproduce the problem, then you can try disabling Comet Cache to see if that solves the problem. If it does, then you can try enabling Comet Cache, excluding the various WooCommerce pages from being cached, and then trying to reproduce the problem again.

Viewing 3 replies - 1 through 3 (of 3 total)
  • The topic ‘Correct Settings for an e-Com Store (Woocommerce)?’ is closed to new replies.