Support » Fixing WordPress » Core Trac page is inaccessible if user-agent contains Firefox 59 or below

  • Resolved acidstout

    (@acidstout)


    Hi folks

    I just noticed that your Trac page is inaccessible if the browser’s user-agent contains the string “Firefox 59” or variations of that at the end of the string. This triggers the nginx to return “error 403 forbidden”.

    For example the following user-agent strings trigger the error:

    
    Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:74.0) Gecko/20100101 Firefox/599
    Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:74.0) Gecko/20100101 Firefox/100
    Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:74.0) Gecko/20100101 Firefox/59.9
    Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:74.0) Gecko/20100101 Firefox/59.0
    Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:74.0) Gecko/20100101 Firefox/5
    Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:74.0) Gecko/20100101 Firefox/4
    Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:74.0) Gecko/20100101 Firefox/3
    Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:74.0) Gecko/20100101 Firefox/2
    Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:74.0) Gecko/20100101 Firefox/1
    
    Setting it to "Firefox 60" or similar or even removing it completely does not trigger the error. Examples which do not trigger the issue:
    Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:74.0) Gecko/20100101 Firefox/74.0
    Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:59.0) Gecko/20100101 Firefox/74.0
    Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:59.0) Gecko/20100101 Firefox/6
    Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:59.0) Gecko/20100101 Firefox/
    Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:59.0) Gecko/20100101 Firefox
    

    Firefox is currently at version 74, so it’s a matter of time when it reaches version 100 which will be blocked by the Trac web-server. Also keep in mind that the “rv:” value is not evaluated.

    Has this been done by intent (and if so, why?) or is it a misconfiguration on side of the web-server (and if so, when will it be fixed)?

    Fun fact: The deprecated and higly unrecommended IE 11 is still able to access the Trac page. 😀

    Sincerely
    acidstout

    • This topic was modified 2 years, 7 months ago by Yui. Reason: moved to requests and feedback
    • This topic was modified 2 years, 7 months ago by Yui. Reason: please use CODE button for code formatting

    The page I need help with: [log in to see the link]

Viewing 2 replies - 1 through 2 (of 2 total)
  • Moderator Yui

    (@fierevere)

    ゆい

    Various user agents are indeed blocked on trac from time to time. They get adjusted on an as-needed basis. Mostly this is because of bots hitting the thing repeatedly, not because of any users doing anything wrong.

    Thread Starter acidstout

    (@acidstout)

    Thanks for clarification.

Viewing 2 replies - 1 through 2 (of 2 total)
  • The topic ‘Core Trac page is inaccessible if user-agent contains Firefox 59 or below’ is closed to new replies.