Support » Networking WordPress » Core Site Pages Not Accessible

  • Resolved ColumbiaWebDev

    (@prfctgdess)


    I have a new WordPress installation…it was a total clean install. Got multisite working, added new subsites, everything is beautiful.

    Except I cannot add pages to the main/core site! It’s set up in a sub-directory structure, so my subsites are mainsite.com/site1, mainsite.com/site2, etc. The wp-config file reads define('SUBDOMAIN_INSTALL', false); and the pages on the subsites work flawlessly.

    Not sure where to go from here…any ideas?! TIA!

    Main site: http://kfcloud.com/
    One of the sub-sites (for comparison): http://kfcloud.com/eskgalaxy

Viewing 15 replies - 1 through 15 (of 15 total)
  • Moderator Ipstenu (Mika Epstein)

    (@ipstenu)

    Lead Plugin Wrangler

    Do you get an error when you add pages?

    No, they appear to create properly. But when you click on one of the pages, it just stays on/returns to the main page.

    For example, if you look at the site that is not working (kfcloud.com) and you click on “Testing Page”, the URL SHOULD be (according to wordpress) http://kfcloud.com/testing-page/ But that doesn’t work. And no, I do not have a subsite named testing-page 🙂

    Moderator Ipstenu (Mika Epstein)

    (@ipstenu)

    Lead Plugin Wrangler

    Check your .htaccess first 🙂 Is it the right one for subfolders?

    well, it’s hosted on a windows server, so I have a web.config file instead. I can post the content of the file if that would help…

    I’m not overly proficient at config files, so this one is just what WP “told” me to set up:

    <?xml version="1.0" encoding="UTF-8"?>
    <configuration>
        <system.webServer>
            <rewrite>
                <rules>
                    <rule name="WordPress Rule 1" stopProcessing="true">
                        <match url="^index\.php$" ignoreCase="false" />
                        <action type="None" />
                    </rule>
                    <rule name="WordPress Rule 2" stopProcessing="true">
                        <match url="^([_0-9a-zA-Z-]+/)?files/(.+)" ignoreCase="false" />
                        <action type="Rewrite" url="wp-includes/ms-files.php?file={R:2}" appendQueryString="false" />
                    </rule>
                    <rule name="WordPress Rule 3" stopProcessing="true">
                        <match url="^([_0-9a-zA-Z-]+/)?wp-admin$" ignoreCase="false" />
                        <action type="Redirect" url="{R:1}wp-admin/" redirectType="Permanent" />
                    </rule>
                    <rule name="WordPress Rule 4" stopProcessing="true">
                        <match url="^" ignoreCase="false" />
                        <conditions logicalGrouping="MatchAny">
                            <add input="{REQUEST_FILENAME}" matchType="IsFile" ignoreCase="false" />
                            <add input="{REQUEST_FILENAME}" matchType="IsDirectory" ignoreCase="false" />
                        </conditions>
                        <action type="None" />
                    </rule>
                    <rule name="WordPress Rule 5" stopProcessing="true">
                        <match url="^([_0-9a-zA-Z-]+/)?(wp-(content|admin|includes).*)" ignoreCase="false" />
                        <action type="Rewrite" url="{R:2}" />
                    </rule>
                    <rule name="WordPress Rule 6" stopProcessing="true">
                        <match url="^([_0-9a-zA-Z-]+/)?(.*\.php)$" ignoreCase="false" />
                        <action type="Rewrite" url="{R:2}" />
                    </rule>
                    <rule name="WordPress Rule 7" stopProcessing="true">
                        <match url="." ignoreCase="false" />
                        <action type="Rewrite" url="index.php" />
                    </rule>
                </rules>
            </rewrite>
        </system.webServer>
    </configuration>

    Moderator Ipstenu (Mika Epstein)

    (@ipstenu)

    Lead Plugin Wrangler

    *ponder* Do you have NOBLOGREDIRECT set in your wp-config?

    No, I don’t think so – definitely not intentionally, and I don’t think anything else in the wp-config looks out of place:
    (slightly edited for posting here to save space/privacy :-P)

    <?php
    /** The name of the database for WordPress */
    define('DB_NAME', ...
    
    /** MySQL database username */
    define('DB_USER', ...
    
    /** MySQL database password */
    define('DB_PASSWORD', ...
    
    /** MySQL hostname */
    define('DB_HOST', ...
    
    /** Database Charset to use in creating database tables. */
    define('DB_CHARSET', 'utf8');
    
    /** The Database Collate type. Don't change this if in doubt. */
    define('DB_COLLATE', '');
    
    /**#@+
     * Authentication Unique Keys and Salts.
     */
    define('AUTH_KEY', ...
    define('SECURE_AUTH_KEY', ...
    define('LOGGED_IN_KEY', ...
    define('NONCE_KEY', ...
    define('AUTH_SALT', ...
    define('SECURE_AUTH_SALT', ...
    define('LOGGED_IN_SALT', ...
    define('NONCE_SALT', ...
    
    /**
     * WordPress Database Table prefix.
     */
    $table_prefix  = 'wp_';
    
    /**
     * WordPress Localized Language, defaults to English.
     */
    define('WPLANG', '');
    
    /**
     * For developers: WordPress debugging mode.
     */
    define('WP_DEBUG', false);
    
    /* enable multisite functionality (WHAT I ADDED) */
    define('WP_ALLOW_MULTISITE', true);
    define('MULTISITE', true);
    define('SUBDOMAIN_INSTALL', false);
    $base = '/';
    define('DOMAIN_CURRENT_SITE', 'kfcloud.com');
    define('PATH_CURRENT_SITE', '/');
    define('SITE_ID_CURRENT_SITE', 1);
    define('BLOG_ID_CURRENT_SITE', 1);
    
    /* That's all, stop editing! Happy blogging. */
    
    /** Absolute path to the WordPress directory. */
    if ( !defined('ABSPATH') )
    	define('ABSPATH', dirname(__FILE__) . '/');
    
    /** Sets up WordPress vars and included files. */
    require_once(ABSPATH . 'wp-settings.php');

    Moderator Ipstenu (Mika Epstein)

    (@ipstenu)

    Lead Plugin Wrangler

    Do posts work?

    And have you tried re-saving the permalinks? Silly, but sometimes…

    Yes, posts work, but the posts get the kfcloud.com/blog/whatever format…I thought maybe the pages didn’t work because they have the same format as the sub-sites? (kfcloud.com/page, just like kfcloud.com/subsitefolder)

    And yes, I tried both resaving the permalinks and changing/saving a new permalink option, just in case. 🙂

    Moderator Ipstenu (Mika Epstein)

    (@ipstenu)

    Lead Plugin Wrangler

    Bleah, I wish I knew more about IIS 🙁

    That’s OK, I appreciate that you’re trying to help! Think reinstalling WP would stand any chance of helping/fixing the issue?

    OK, I haven’t solved the problem so much as identified a work-around. The issue seems to have something to do with the permalink settings and my server setup.

    In the main/core site, I set the permalink structure to the default (the ?p=123 format). On the subsites, I can use any pretty permalinks I like. Problem “solved”!

    This solves my problem because this is a personal network of sites and I don’t care about SEO or indexing. If you want to still have the “pretty” permalinks on your core site, then I don’t have a solution, but for me, this works.

    I suspect the issue lies with WordPress Rule 4, for anyone trying to actually solve this problem:

    <rule name="WordPress Rule 4" stopProcessing="true">
                        <match url="^" ignoreCase="false" />
                        <conditions logicalGrouping="MatchAny">
                            <add input="{REQUEST_FILENAME}" matchType="IsFile" ignoreCase="false" />
                            <add input="{REQUEST_FILENAME}" matchType="IsDirectory" ignoreCase="false" />
                        </conditions>
                        <action type="None" />
                    </rule>

    It seems to be treating pages (files) the same as directories, which could be why I can’t create a new page on the core site.

    Moderator Ipstenu (Mika Epstein)

    (@ipstenu)

    Lead Plugin Wrangler

    I’m setting up an nginx box so I can test all this stuff 😉 IIS is still a mystery. Maybe I’ll talk to GoDaddy again about that…

Viewing 15 replies - 1 through 15 (of 15 total)
  • The topic ‘Core Site Pages Not Accessible’ is closed to new replies.