Support » Fixing WordPress » Core or Plugin update: "Could not create directory.: /httpdocs"

  • Resolved TroyMcGinnis

    (@troymcginnis)


    Hi Guys,

    I’ve been searching for the solution to this for a while and now I’m looking here to get some help. The issue I’m having is that on one of the WordPress sites that I manage, I have been receiving the following message when attempting to upgrade the Core WordPress files or any of my Plugins:

    Downloading update from http://wordpress.org/wordpress-3.5.2-partial-1.zip…
    
    Unpacking the update…
    
    Could not create directory.: /httpdocs
    
    Installation Failed

    I have tried running chmod 777 on the wp-content directory as well as the root public_html directory (which I know is not at all secure). This is the ONLY site that has been giving me issues out of approximately 20 sites.

    The servers are all VPS servers running the latest distro of CentOS with Apache, MySQL and the latest version of PHP.

    Any assistance would be greatly appreciated!

    -T

Viewing 11 replies - 16 through 26 (of 26 total)
  • Incredible. That did it!

    Thanks, Puma.

    Thanks guys for lifesaving! 🙂

    Hey guys! I’ve read all the comments here, and made the change in the config file, but I’m still getting this issue.

    My server is IIS 7, with PHP, and MySQL and WordPress all working fine, I just can’t get the plugins to update or delete or install.

    Any help will be really appreciated.

    Thanks!

    I followed the instructions from Puma85.No joy, still says could not create directory 🙁

    Andrew Nevins

    (@anevins)

    WCLDN 2018 Contributor | Volunteer support

    Then it is unlikely you are experiencing the same issue that TroyMcGinnis did 8 months ago.
    You can create a new thread here: https://wordpress.org/support/forum/how-to-and-troubleshooting#postform

    Hey Julianwave – on what server did you install WP? I have it installed on IIS 7, I was able to resolve this issue by making sure that the wp-content folder had “full access” for IIS-IUSERS account in the server. It’s a bit annoying to fiddle around with those settings, but that resolved it for me.

    You can also set file permissions in an FTP client to 765, but this won’t work for IIS.

    I think this is all about permissions, and if that’s the case then you can find a bunch of threads on how to set folder/directory permissions on your server. Good luck!

    -Focet

    It turns out a load of files had been uploaded without my knowledge and the problem was simply that I’d run out of space.

    So, future visitors to this thread, learn from my mistake and before you do anything else check there is actually space on the server for your plugins to update!

    Hello.. this is just a simple issue.. just ssh on the server.. download the plugins manually and unzip + copy it to the /var/www/yourwebsite/wp-content/plugins.. this will solve the problem on spot. Next time there is an update that screen to use ftp/ftps or “cant create folder” wont appear again^^^

    regards
    nitin j mutkawoa

    Thank you All,

    I had the same problem, But after following the the instructions provided by Puma85, Thank you.
    I still get the same problem, so changed the permissions of each folder under and tested the plugins after each change, here is the steps i found to resolve the issue:
    1. follow the instructions Puma85 provided: http://www.hongkiat.com/blog/update-wordpress-without-ftp/
    2. Change the permissions for the wp-content and plugins folders:
    sudo chmod 777 Your_wordpress_root_folder/wp-content
    sudo chmod 777 Your_wordpress_root_folder/wp-content/plugins

    3. Install the plug-in, it should work fine.
    To change back the permission for protecting the wordpress contents and plug-in, otherwise you can leave it as is if the security is not a big concern :
    4. change back the original permission :
    sudo chmod 751 Your_wordpress_root_folder/wp-content
    sudo chmod 751 Your_wordpress_root_folder/wp-content/plugins

    Hope this will help.

    Good Luck,
    Mohamed Soliman

    It worked 🙂
    Thanx, Puma

    Thanks mhsoliman, it worked for me!

Viewing 11 replies - 16 through 26 (of 26 total)
  • The topic ‘Core or Plugin update: "Could not create directory.: /httpdocs"’ is closed to new replies.