Support » Fixing WordPress » Core or Plugin update: "Could not create directory.: /httpdocs"

  • Resolved TroyMcGinnis


    Hi Guys,

    I’ve been searching for the solution to this for a while and now I’m looking here to get some help. The issue I’m having is that on one of the WordPress sites that I manage, I have been receiving the following message when attempting to upgrade the Core WordPress files or any of my Plugins:

    Downloading update from…
    Unpacking the update…
    Could not create directory.: /httpdocs
    Installation Failed

    I have tried running chmod 777 on the wp-content directory as well as the root public_html directory (which I know is not at all secure). This is the ONLY site that has been giving me issues out of approximately 20 sites.

    The servers are all VPS servers running the latest distro of CentOS with Apache, MySQL and the latest version of PHP.

    Any assistance would be greatly appreciated!


Viewing 15 replies - 1 through 15 (of 26 total)
  • Odd that it is trying to create /httpdocs when that is a directory that usually contains all of your site’s files. Do you have your WP install setup in any special way that would cause it to try to create that directory?

    Usually when WP is doing an upgrade it will place files into /wp-content/upgrade

    Jarret, no special setup with this install of WP. I have read lots of people mentioning that they were receiving errors that would state something like…

    Could not create directory.: /httpdocs/wp-content/plugins/...

    Not sure why its attempting to create the root html directory either. It’s leaving me stumped.

    Do you have any update on this topic? I have the exactly the same problem. It worked fine before, but now it gives me this error.

    Is it maybe something server-related?

    I have not found a solution to this yet. The WordPress install has just moved to a new server and the issue is persisting.

    I’m considering just doing a manual update but would really like to be able to get the auto updates working.

    Anyone else have any thoughts on this?

    It looks like this issue is actually occurring for the core update as well as for the plugins ( It could be a server issue, but I’m not sure what.

    Any difference is that I don’t have that trailing / before httpdocs

    ‘Downloading update from…

    Unpacking the update…

    Could not create directory. httpdocs’

    I’m now trying to find out what I changed lately… it’s bin a while though since anything changed.

    Don’t know if this helps, but when I change the address in wp-config, it creates the new folders to store the upgrade..
    for example, when I add system to the address as shown below, it creates nicely new folders and stores the upgrade files in there.
    ‘define(‘FTP_BASE’, ‘httpdocs/system/’);
    define(‘FTP_CONTENT_DIR’, ‘httpdocs/system/wp-content/’);
    define(‘FTP_PLUGIN_DIR ‘, ‘httpdocs/system/wp-content/plugins/’);’

    The installation error is then as follows:
    ‘Downloading update from…
    Unpacking the update…
    Installing the latest version…
    Removing the old version of the plugin…
    Could not remove the old plugin.
    Plugin update failed.’

    but as soon as I change it back it gives problems again..

    Looks like you’re getting closer.

    That last error you’re getting looks like a permissions issue. Try running chmod 777 on the wp-content directory then try the upgrade again. Make sure to change your permissions back afterward.

    I’ll try defining the those FTP variables and post back here.

    problem remains the same. No difference

    usually it happens for write permission for apache on your server. can you give apache write permission as much as root on your server?

    I don’t know, what is the difference?
    I use parallels panel to change the chmod permisions…

    for parallels the user name is something like “pcl” or close to it. more effective is to use ssh or rdp

    I’m sorry, but could you explain (maybe step-by-step)what I need to do.
    I don’t understand what you’re trying to say.
    thanks for you help!

    How many sites you have in your server? are all of them got the same problem? if not then obviously it wount be a server issue. However, to give it a try…
    First take backup as if you don’t have backup so many thing happens. then may be follow this tutorials and give a try.


    I found this link:

    And after changing the FS_method to direct, it worked perfectly!! 😀
    Basically add this line to your wp-config.php file:

    good luck!

Viewing 15 replies - 1 through 15 (of 26 total)
  • The topic ‘Core or Plugin update: "Could not create directory.: /httpdocs"’ is closed to new replies.