Support » Fixing WordPress » Core Automatic Upgrade Hangs at Download

  • I’ve used Automatic Upgrade for as long as I’ve used WordPress and have never had a problem. Since upgrading to 2.8.1 it no longer works.

    The symptom is this: When I attempt to Automatically upgrade, the process goes fine until I click Upgrade Automatically. When I do that, the progress screen comes up and it just hangs at Downloading x.x.

    Watching the directories in my Webspace Explorer, a new file is created at wp-content but it stays at size 0. I’ve tried changing permissions on all of the directories that I think might be involved (root, wp-content, upgrade) but nothing makes any difference.

    One thing I just thought of was that I had recently uploaded the entire site again from my machine out of source control and I thought perhaps that the owner and group had gotten messed up. I can’t check that from the Webspace Explorer. However, I tried the permissions set to 777 so I don’t think this should have been an issue.

    Any help’s greatly appreciated.

Viewing 5 replies - 1 through 5 (of 5 total)
  • Are you hosted with 1&1 by any chance? Try adding:

    AddType x-mapp-php5 .php

    to your root WP .htaccess file.

    That did it. Thank you so much, esmi!

    Could you tell me what exactly that did?

    I can confirm that this resolves this issue with hostees; it will also fix a couple other anomalies such as failure to get wordpress information downloads to your dashboard-admin page. These issues have occurred since the 2.8.4 upgrade.

    I am not exactly sure what this code does but I have found to have a couple operational glitches as it attempts to support wordpress activities. For ex., I no longer use the flash uploader for images and use only the browser uploader option because I suspect 1and1’s vanilla operational structure is incompatible (images do upload but the image management screen fails to appear so one has to go to media menu and insert it manually from there). I am sure there is code to fix this but I am also trying not to be a computer science major in my later life.

    I am having the same problem and I host with BlueHost.

    I tried to add

    AddType x-mapp-php5 .php

    to my root WP .htaccess file, but core upgrade blew up. I clicked it and all the PHP code spilled over the screen. It was quite scary. PHP code in a browser is so unexpected, I at first thought I broke something in the browser.

    If anyone knows why the upgrade hangs at the download in BlueHost please let me know.

    I just fixed this with a Bluehost install: it’s not a php addtype issue, it the default maximum memory. Add the following line to your wp-config.php file (anywhere should be fine, but I added it toward the top of the file):

    define(‘WP_MEMORY_LIMIT’, ’64M’);

    After that, it worked fine (and fast — blink and you’ll miss it).

Viewing 5 replies - 1 through 5 (of 5 total)
  • The topic ‘Core Automatic Upgrade Hangs at Download’ is closed to new replies.