Support » Fixing WordPress » Core 5.51 breaks all versions php greater than 7.0

  • Resolved 1webdesigners

    (@1webdesigners)


    We upgraded from 7.0 php to 7.4 and added 7.2 and 7.3

    Most sites on our server immediately broke, they were running updated plugins and 5.51 core

    A few sites ran fine, until we upgraded them to core 5.51

    So 5.51 core will not run on our server without breaking sites IF we add more than woocommerce, it’s the only plugin that works on our server with core 5.51

    I found some info on cpanel about enabling nd_mysqli and another old php V 5.0 file

    I found something on this site about centos needing a php_mysgl extension

    Server is Centos 7.80
    We have 5.6 php, 7.0 php that works fine, we installed 7.2, 7.3 and 7.4 and those break all sites as soon as we upgrade to core 5.51

    Then if disable all plugins and run 5.51 core on 7.4 core works, if we run woocommerce only it works, as soon as any other plugin in activate, it crashes

    Error messages range from
    Critical Error
    White screen of death
    http 500 error

    We have over 100 WP sites
    All use OnePress Theme
    Then many use Woo

    We use about 20 plugins on the sites, never had any issues

    We did have issue while ago with ultiate seo breaking stuff while we were under 7.0 php with older cores

    So we just disabled that plugin and had no real issues until we started running php higher than 7.0

    HELP

    The page I need help with: [log in to see the link]

Viewing 9 replies - 1 through 9 (of 9 total)
  • Moderator t-p

    (@t-p)

    Error messages range from
    Critical Error
    White screen of death
    http 500 error

    Errors like these are logged. Please check the error logs on your server for a more specific error message, which may give a clue to why this is happening on your website/server. If you need help locating them, ask your hosting provider to help you with that.

    Meanwhile you can also try:
    – Try manually resetting your plugins (no Dashboard access required). If that resolves the issue, reactivate each one individually until you find the cause.
    – If that does not resolve the issue, access your server via SFTP or FTP, or a file manager in your hosting account’s control panel, navigate to /wp-content/themes/ and rename the directory of your currently active theme. This will force the default theme to activate and hopefully rule-out a theme-specific issue (theme functions can interfere like plugins).

    We ruled out themes by testing issue with 2020
    That was first thing we thought, since that is the one common thing on all sites, we use only one theme.

    My host says the php_mysqlcld (?) is on all versions of php installed from 7.2 to 7.4

    So it might be the nd_mysqli file and the associated one since goes back to V 5.0 php and this server only started with 5.6

    I looked at error log on a couple of sites we were testing by going from 7.0 to 7.4 and saw nothing in error log within cpanel, it shows a couple of error logs and the only error we really saw was bad logins from hackers.

    So it’s core related, things work on 7.4 until we update core on any site to 5.51 and then bingo, it breaks everything, and then only works removing all plugins then turning on woo, and it works and as soon as any plugin is added to core and woo in Centos it crashes.

    Moderator Steven Stern (sterndata)

    (@sterndata)

    Forum Moderator & Support Team Volunteer

    Just FYI, these are the PHP packages I’m running on CentOS 7, using the php74 repo from ius.io.

    $ rpm -qa |grep php
    php-pear-Net-Curl-1.2.5-10.el7.noarch
    php74-pecl-imagick-3.4.4-4.el7.ius.x86_64
    php74-mysqlnd-7.4.10-1.el7.ius.x86_64
    mod_php74-7.4.10-1.el7.ius.x86_64
    php-tcpdf-6.2.26-1.el7.noarch
    php74-pdo-7.4.10-1.el7.ius.x86_64
    php74-opcache-7.4.10-1.el7.ius.x86_64
    php-tcpdf-dejavu-sans-fonts-6.2.26-1.el7.noarch
    php74-cli-7.4.10-1.el7.ius.x86_64
    php74-bcmath-7.4.10-1.el7.ius.x86_64
    php-fedora-autoloader-1.0.1-2.el7.noarch
    phpMyAdmin50-5.0.2-3.el7.ius.noarch
    php74-devel-7.4.10-1.el7.ius.x86_64
    php74-gd-7.4.10-1.el7.ius.x86_64
    php74-fpm-7.4.10-1.el7.ius.x86_64
    php74-process-7.4.10-1.el7.ius.x86_64
    php74-common-7.4.10-1.el7.ius.x86_64
    php74-mbstring-7.4.10-1.el7.ius.x86_64
    php74-intl-7.4.10-1.el7.ius.x86_64
    php-php-gettext-1.0.12-1.el7.noarch
    php74-xml-7.4.10-1.el7.ius.x86_64
    php74-tidy-7.4.10-1.el7.ius.x86_64
    php74-pecl-zip-1.19.0-1.el7.ius.x86_64
    php74-soap-7.4.10-1.el7.ius.x86_64
    php74-json-7.4.10-1.el7.ius.x86_64
    

    and I’m using php-fpm with apache. 5.5.1 works perfectly.

    Then if disable all plugins and run 5.51 core on 7.4 core works, if we run woocommerce only it works, as soon as any other plugin in activate, it crashes

    WordPress 5.5.1 supports PHP version 7.0 and above. It is not core related. It is about the “other plugin” you mentioned.

    Some plugins are not yet updated to be compatible with the PHP 7.4. Try to switch to PHP 7.3, which is supported by most plugins already.

    This is the issue, sites with old core 5.4 whatever WORK on 7.4, all the plugins of the site work, as soon as we update the core, IT CRASHES the plugins

    So while everyone is saying it’s plugins, it’s not, the plugins work on 7.4 IF we have the old core.

    So what is crashing the sites?

    It’s not plugins, it’s the core, so if we want to run 5.51 core with plugins that work on 7.4 with older core versions, we now have to remove almost every plugin running 7.4 php with 5.51 core.

    It’s core issue on my server.

    Not plugins

    If it was theme or plugin they wouldn’t work with older core versions, it’s the latest core that is wreaking havoc, now it’s probably something on the server that isn’t enabled that core 5.51 needs

    I hope this makes sense to someone that understands, plugins are fine and so is theme on 7.4, it’s only updating the core to 5.51 that is crashing everything

    Here’s my server running lots of plugins updated, and an old core with 7.4 php

    https://1lawyer.org/

    It works

    If I update to 5.5.1 core

    It will be like the rest of sites with updated core broken

    No woo on this site, but this is what I’m dealing with

    So it’s not the plugins, it’s not the theme, it’s the 5.5.1 core that is breaking stuff IF I upgrade any site to 5.5.1 core

    Core is 5.4.2

    This site has most of the stuff we use

    The same theme
    Slider 3
    SEO
    Contact Form
    Few other plugins

    So everything works under 7.4 php

    As long is core is not 5.5.1

    So it’s the core

    Moderator Yui

    (@fierevere)

    ゆい

    Can you check the debug output?

    a. PHP error log
    b. https://wordpress.org/support/article/debugging-in-wordpress/

    Yui much thanks that’s what I need
    I added debug and found issues with an old cpanel plugin and ultimate seo
    So we deleted both and then updated to 5.5.1 and bingo it works

    So two old plugins were raising flags in 7.4 in older cores and working but 5.5.1 broke them so white screens and critical screens and 500 error

    Now that I know what plugins are choking 5.5.1 fatally they are gone

    So beware anyone of cpanel plugin and ultimate seo plugin

    They will crash 5.5.1

    Thanks everyone

    Resolved cpanel and ultimate seo plugin issues

    Yui debug info gave me the info to see what was happening

Viewing 9 replies - 1 through 9 (of 9 total)
  • You must be logged in to reply to this topic.