Support » Themes and Templates » [Resolved] Copyright Footer

[Resolved] Copyright Footer

  • Hi,

    The copyright reads the name of the blog. I need it to read the name of the company. I see a variable ‘name’ in the code, but don’t know how to change that to the company name.

    Thanks for the help (and the nice theme),
    Steven (www.executive-mentor.com)

Viewing 7 replies - 1 through 7 (of 7 total)
  • Hello Sam!

    to change the name on the footer you have to edit your theme’s footer.php.
    The safest way to do that is creating a Child Theme, this will prevent any modification you make to your theme files so when the parent theme updates you won’t lose any changes you made.
    Instructions on how to make a child theme can be found HERE.

    Once you’ve created your Child Theme, make a copy of footer.php and put it in your Child Theme’s folder and edit that.
    At line 125 you’ll find:

    © <?php echo date("Y") ?> <a href="<?php echo home_url(); ?>" title="<?php bloginfo('name'); ?>"><?php bloginfo('name'); ?></a>

    Just replace it with

    © <?php echo date("Y") ?> <a href="<?php echo home_url(); ?>" title="YourCompanyName">YourCompanyName</a>

    Let me know if you need help in the process ok? 🙂



    Made the child theme:

    1. Created directory on same level as Hemingway called hemingway-child.
    2. Put the info in for style.css referencing hemingway.
    3. Activated theme (shows as child theme).

    But, text only, no formatting, no graphics, nothing. I can’t find any information on what I did wrong. (It seemed pretty simple). Anything special need to be done for Hemingway?


    Moderator stephencottontail


    When I look at your site (12:53 Mountain time), I don’t see your child theme’s stylesheet being loaded. Did you switch back to the Hemingway theme?

    Same here, Sam can you please copy/paste what’s in your Child Theme style.css?

    Thanks Guys, I really appreciate the help.

    It looks like it is working. I have it here to play with now http://www.executivementor.com/wordpress and it seems to be working. The problem is in WordPress, when I look at the Themes page, the preview is blank, like a transparent Photoshop page, no preview. But it works and the footer fix works.

    I don’t understand it, but I can live with it. Thanks so much for the fast response. Hopefully I can pay it forward when I get a little better at this. (I’m still using iWeb for the main site.)


    Cool I’m glad it helped!
    About the preview…no worries we can fix it too.
    Just copy and paste the “screenshot” image from your parent theme to your child theme folder.

    If you want you can even create a custom image for the preview, just make sure you it’s the same size as the original picture 😉

    If everything’s ok remember to mark the topic as solved so others know.
    Let me know if you need any help


    Thanks guys!


Viewing 7 replies - 1 through 7 (of 7 total)
  • The topic ‘[Resolved] Copyright Footer’ is closed to new replies.