WordPress.org

Support

Support » Installation » [Resolved] Copying Site to a Subdomain

[Resolved] Copying Site to a Subdomain

  • I copying my site The Sydney Visitor to the subdomain new.thesydneyvisitor.com. The reason is that i want to change the design while my old site is still active.

    What I have done so far:
    Copied all the files to the sub-domain directory using ftp.
    Created a new database
    Exported the old site database and imported it to the new database
    Edited the wp-config file (in the subdomain directory) to point to the new database
    Updated the wp-options table to reflect the url change
    Run this query to update the URL change in the posts
    UPDATE wp_posts SET guid = replace(guid, 'http://www.thesydneyvisitor.com','http://www.new.thesydneyvisitor.com');

    The problem:
    After doing all these when i trying accessing the site using the subdomain url i get the following errors:

    Warning: require(/home/rapidtem/public_html/new/wp-includes/load.php) [function.require]: failed to open stream: No such file or directory in /home/rapidtem/public_html/new/wp-settings.php on line 21

    Fatal error: require() [function.require]: Failed opening required ‘/home/rapidtem/public_html/new/wp-includes/load.php’ (include_path=’.:/usr/lib/php:/usr/local/lib/php’) in /home/rapidtem/public_html/new/wp-settings.php on line 21

    Kindly Assist I am stuck.

    Thanks in advance

Viewing 4 replies - 1 through 4 (of 4 total)
  • Subdomains are not accessed via www. prefix so the correct url would be:

    http://new.thesydneyvisitor.com

    Thanks threestyler,

    I have made the changes to url but still the same problem persists.

    Are you sure you have moved the complete WordPress installation to the new directory? As the error suggests it cannot find wp-settings.php in that location.

    Also if you already ran the above query you may also need to run it as follows:

    UPDATE wp_posts SET guid = replace(guid, 'http://www.new.thesydneyvisitor.com','http://new.thesydneyvisitor.com');

    Thanks Threestyler,

    The problem was with wp-includes some of the files were not copied.

    I really appreciate your help.

Viewing 4 replies - 1 through 4 (of 4 total)
  • The topic ‘[Resolved] Copying Site to a Subdomain’ is closed to new replies.