Support » Plugin: BackUpWordPress » Copy the base instead of the whole site

Viewing 1 replies (of 1 total)
  • Plugin Author katmoody

    (@katmoody)

    Hi there –

    Thank you for your comment and review. It sounds like the files occasionally don’t complete their backup for you – I’m sorry for that inconvenience.

    We try to go through some basic troubleshooting to see if we can determine why a backup isn’t completing all the time so if it’s possible to tweak either a schedule or something on the server you can do so.

    You mention you don’t have problems with the database, just occasionally with the complete backup. Since this likely means that the files are the actual problem, let’s try creating a new files-only backup to see if it completes. If it does, that’s great! You might just need to run two schedules – one for the files and one for the database. The complete backup might just be a little too much or run a bit too long for your server.

    If you aren’t able to complete the files-only backup, try to exclude your /wp-content/uploads folder, then run a manual backup. Does this work? If so, we know the size of your backup is probably hanging up your server. You can try using our “excludes” functionality to reduce the size of the files you need to backup, or to split them. You can read more here about how to do that: https://bwp.hmn.md/support-center/troubleshooting/splitting-backup-workload/

    Can you check with your host about whether they block use of the MySQLDump Command and/or the Unix Zip Command? If they do, you might see if they’re able to enable them at all – both commands are more performant than the backup options available on fall back.

    If you find that you sometimes have problems, but not all the time, ask your host or search through their FAQs to see if they have any hard limits set on their server for CPU usage, max_execution_time or other variables. See if you are able to set them in your own php.ini file. Sometimes these limits will mean that a backup runs too long or at the same time as other functionality on your site, which your server won’t like.

    In your php.ini (If you’re not sure how to make changes to your php.ini, your host may have more information to help you.) try making sure the following values are set to at least these minimums. If you have a large site think of increasing them further. (Contact your host to find out if they enforce PHP or CPU max timeouts).
    – memory_limit = 256M
    – max_execution_time = 120
    – max_input_time = 120

    Hopefully this can help you out or give another user a starting point. Thanks again for your review and comment – we appreciate you!

    Kat

Viewing 1 replies (of 1 total)
  • The topic ‘Copy the base instead of the whole site’ is closed to new replies.