Support » Plugin: Duplicator - WordPress Migration Plugin » Copy site to local installation on Instant WordPress

  • Trying to copy my site down to try playing with it a little without risking the ‘real’ site, and using Instant WordPress to run on my desktop pc. Not entirely sure where to put the downloaded files since obviously my local installation is ‘virtual’ and doesn’t have folders to put it in, but followed the advice from a previous question (https://wordpress.org/support/topic/duplicator-with-instant-wordpress?replies=5) and put the installer and the package in the /iwpserver/htdocs/wordpress folder after deleting everything that was currently in there.
    The question also said I’d have to edit the config.ini, so I’ve done that, but now stuck – I just can’t get the installer to run in local environment, as installer.php simply opens in my editor instead. Even if I force it to open in IE, I get a IE popup box asking if I want to open or save the file, and clicking Open opens it in my editor again.
    I’m gonna feel so stoopid, but how do I actually open installer.php to run it rather than edit?

    https://wordpress.org/plugins/duplicator/

Viewing 5 replies - 1 through 5 (of 5 total)
  • Plugin Author Cory Lamle

    (@corylamleorg)

    Hey ontour,

    Checkout this question on the FAQs page I believe it may help or provide some clues about this issue:
    -> Browse to: http://lifeinthegrid.com/duplicator-faq
    -> Find question: “Why do I get plain/text, binary text, parse errors or a download prompt when browsing to the installer?”

    Hope that helps!

    Hi Cory
    Thanks for the reply. I did read that section before I posted here. Unfortunately I couldn’t make any sense from that section, because it suggested editing one of two files (either httpd.conf or .htaccess). But, as per the instructions, I don’t HAVE either of those files – the directory only has the two files generated by Duplicator from my original site.
    To explain better: Instant WordPress had the whole wordpress files (with wp-admin, wp-content, etc) in a folder called htdocs, and I’ve deleted everything out of that folder – the instructions said it should be an empty folder.

    Plugin Author Cory Lamle

    (@corylamleorg)

    Hey Ontour,

    You can manually unzip the archive.zip on the server then browse to the .htaccess file which should be in your archive.zip. If one isn’t there then you may have to manually create one.

    If you don’t manually create one then when you run the installer.php on step 1 and under advanced options you will need to check the ‘Manual Extraction’ checkbox to run the installer. This will generate a new .htaccess file when its done and rename the old one to .htaccess.bak, that should hopefully at least get you to run the installer.

    You may also post a thread to the Instant WP forum they will now how to tweak the web server so that it processes the PHP file correctly, which seems like the core issue…

    Hope that helps!

    Cory
    I won’t repaste here the instructions from lifeinthegrid.com/support/knowledgebase.php?article=12#faq-trouble as you already have them, but I’ve just gone back and checked – I’m afraid NOWHERE in that help file is there any indication that, if you need to apply the edits suggested in the htaccess file. How is the user supposed to know that?! Well, I gave up trying to get it to work with a local installation, and instead copied it to another domain. Empty folder, spare database details to hand. Hey presto, the installer actually runs.
    And now we have some text fields, the first of which is already filled in with ‘localhost’. Okay, since you prefilled it, I’m gonna guess it’s right. Next, is a field marked ‘Name’. Note that, *Name*. Not ‘Database Name’, not ‘User Name’, not ‘Domain Name’, just ‘Name’. That’s really helpful, isn’t it? Okay, I’ll hope that it actually means Database Name, so I’ll fill that in there. Next is ‘User’, and then Password. And hit Test Connection. Result – “Server Connected: Fail, and Database Found: Fail. Well that’s strange, I know I filled in the names of an existing database and its associated user correctly! Ah well, let’s just create a new database instead then. After all, there’s a checkbox helpfully marked Create New Database.
    So create a new database name, and user, and password, and hit Test Connection. Exactly teh same Fail result. Well yes of COURSE the Database name isn’t ‘found’, I’m just *creating* it, that’s why I pressed the “Create New Database” button!
    See, that’s what’s making this plugin WORSE than useless. Because not only can novice users not use it, but they end up worse off than if they’d never tried. Because not only don’t they get the result they were looking for, now they feel demoralised, stupid, helpless. Clearly I’m all of the above, because I not only have no idea how to proceed, I’ve actually lost the will to try and find out what’s wrong – I know I’ll spend hours, and then come up with a complete impasse because the help file didn’t tell us what we needed to do. I’ve deleted it, and the plugin, and I’ll have to do without it.

    Plugin Author Cory Lamle

    (@corylamleorg)

    Hi Ontour,

    First off, I apologize you had a bad experience with the plugin, we are definitively trying to make it better for the community as a whole. It is somewhat technical and there is a learning curve, especially if its your first time…

    We will definitely take some of your comments and see if we can improve the plugin to be more user friendly. The issue you had with creating the database on the fly with the “Create Database” option is an issue on some hosts as they don’t allow for the plugin to create the DB. The hosts require you to create it through the cPanel unfortunately. We will look to cleanup some of the messages to be more clearer in the future.

    For what its worth, none of this is really an easy process, especially trying to develop the software for everyone, but your honest feedback definitely helps us to improve things to make it less of a struggle.

    Again sorry you ran into those issues!

Viewing 5 replies - 1 through 5 (of 5 total)
  • The topic ‘Copy site to local installation on Instant WordPress’ is closed to new replies.