Support » Plugin: Duplicate Post » Copy also the “post format” settings

  • Resolved Al Simmons

    (@maltekebbel)



    Hello,

    can you add support also the “post format” of a post when you copy a post / custom post type?

    best

Viewing 12 replies - 1 through 12 (of 12 total)
  • Plugin Author Lopo

    (@lopo)

    Hi,
    it’s already copied, as every taxonomy is, unless you disable it under Settings→Duplicate Post, field “Do not copy these taxonomies”.

    If post format is not copied, there is probably some incompatibility between my plugin and some other: the only other report about post formats was by a user who had some complicate tweaking of Advanced Custom Fields configuration…
    Do you have any plugin installed that may be relevant in post format management?

    it is not working with “custom post types” but it is working with normal post… i will disable all plungins and have a check

    • This reply was modified 1 year, 11 months ago by  Al Simmons.
    Plugin Author Lopo

    (@lopo)

    Hi,
    how’s the custom post type been created, and the post format taxonomy attached to it? I suppose it’s been done through a plugin, or by your theme?

    I deactivated the plugin ACF. But there is the same problem that it is not copying the “post format” for custom post types

    The custom post type is created by the plugin “Custom Post Type UI 1.4.3” and in the plugin i add the support for “post formats” but it is not duplicate the post format.

    Plugin Author Lopo

    (@lopo)

    How do you choose the post format when editing a post of your custom post type? With the standard WordPress UI or do you have a ACF field for that?

    I did it now with the normal “wordpress ui” and it is still the not copying the post format

    I tried also other plugins which does the duplicate post feature too, but they all do not copy the post format ?! hm

    but with the plugin “Custom Post Type UI 1.4.3” https://de.wordpress.org/plugins/custom-post-type-ui/ which is creating the custom post type. the “post format” is under the field “supported” not under the field taxonomies. ?

    Plugin Author Lopo

    (@lopo)

    Seems I’m able to replicate the issue, I’m going to do a bit of debugging to find what’s wrong

    Plugin Author Lopo

    (@lopo)

    Hi,
    I think I’m in the right way to solve the issue, maybe I’ll have to contact the CPT UI developers to warn them about some quirks regarding Post Formats.
    I’ll keep you informed, thanks for reporting the problem!

    Plugin Author Lopo

    (@lopo)

    Hi,
    version 3.1, out now, should probably fix the issue.

    Can you confirm so I can mark as resolved?
    Thanks!

Viewing 12 replies - 1 through 12 (of 12 total)
  • The topic ‘Copy also the “post format” settings’ is closed to new replies.