Support » Fixing WordPress » Coppermine integration plugin for WordPress problems

  • I get a “No input file specified” when I try to upload. I have copied the coppermine to wp-content/plugins, and copied the cpg135 into the coppermine folder. Then I have setup the plugin succesfully, although it says Invalid prefix ? (Sharing the connection with WordPress). afterwards I have activated the plugin

    what am I doing wrong here?

Viewing 14 replies - 1 through 14 (of 14 total)
  • That’s the first time I hear this problem 🙁

    This is what I found on coppermine support.
    Unfortunately this will not work with the plugin.

    You can disable the upload link in the configuration screen.

    To help me fix the problem in the next version:
    – Do you have to disable multiple file uploads in coppermine when you use it normally ?
    – What browser do you use ?
    – Does it work if you use another browser ?


    Im using Safari, and tried on firefox with no luck. Then I noticed that the upload button under write new post points to wp-admin/wp-upload.php wich was nowhere to be found. Then I looked in the cpg folder og coppermine and found wp-upload.php and wp-login.php

    I put wp-upload.php in the wp-admin folder and now I dont get the no input file message no more, but just a blank screen.

    I figured wordpress was pointing to a blank end. This did not solve my problem at all. So does the above give u a clue to whats wrong? I must admit I lost my php virginity a couple of days ago.

    Oh, the message in the configuration screen said:
    “connection successful, but table not found, invalid prefix? (sharing connection with WordPress)”

    Sorry, I read over that the first time. You’ll have to change the table prefix to match coppermine’s. You can find it in


    $CONFIG['TABLE_PREFIX'] = 'cpg133_'; <-this value

    This is needed for the upload and the display of pictures to work.

    hey stilgar

    I got rid of the invalid prefix? with your fix above. Still when I choose upload when writting a post I just get a blank screen. The upload button points to wp-admin/wp-upload.php

    I dont remember seeing anything in the installation guide about putting anything in the wp-admin folder so I tried putting the wp-upload.php in the wp-admin folder without any luck ( I was just guessing)

    So my status now. I got coppermine working on its own, and got rid of the invalid prefix. But I can still not upload. Im sure the problem is at my end, as I am very very new to php.

    Any other suggestions to solve my problem as I was really looking forward to using ur plugin.

    Maybe a stupid question, but you pressed ‘save settings’ after you tested the database connection, right?

    If that is the case, you should check if this value is correct in the Coppermine configuration page (not the plugin configuration page):

    Target address for the 'See more pictures' link in e-cards

    It should point to your gallery.

    Target address for the ‘See more pictures’ link in e-cards points to /wp-content/plugins/coppermine/ I do belive that is the right config, but then again Im not sure.

    From the coppermine config: Cookies settings
    Name of the cookie used by the script (when using bbs integration, make sure it differs from the bbs’s cookie name) points to cpg135_ just like the plugin.

    Still Im wondering if it was the right thing to do to move the wp-upload.php from the cpg folder to wp-admin/?


    The ‘see more pictures’ link should point to coppermine (probably /coppermine, /cpg or /gallery), not to a wordpress directory.

    And the wp-upload.php file must be in the coppermine directory, since it looks for coppermine files in that directory.


    Stilgar – do you have a support forum for this plugin? I cannot get the insertion bar to show up at all. Only the Upload Files and More Pictures links show up. And yes, I have gone to the configuration page and set ‘Use image inserter’ to YES. Maybe there is a problem with using this plugin with WP 1.5.2? I have tried logging in with both Internet Explorer and Firefox but the insertion bar does not show up on either one.

    Another question: when I add an album to a post is there a way to get rid of the ‘visit (name of photo album)’ link at the bottom? I want my users to upload and view all photos via the WP interface and not even know that Coppermine is there.

    hcm: so I see you here too 🙂 The support forum is here (the plugin page).

    If you enabled user integration, you will only see your own pictures in the bar, unless you set the option “Display everybody’s pictures”. If you didn’t, the listing is limited to public pictures.

    There is no elegant way to disabled the link at the moment, but you can hide it by editing the coppermine.css file and adding “display: none; ” in the .cpg-album-label block.

    that’s not really a forum. it’s just user comments in reverse order which makes it very difficult to search and follow the discussion.

    i have tried every single configuration for this plugin and it does not under any circumstance show the insertion bar. only the ‘Upload Files’ and ‘More Pictures’ links are ever shown. has this been tested with WP 1.5.2 or just 1.5? as i said before, i’m using 1.5.2 and i’m wondering if this is a compatibility problem?

    No compatibility problem.

    The comments on my page are listed in order, but paged. If you need to search in them, use the ‘Show all’ option. It would be nice if you used that page for support because it can be useful to other users, and for me to make a FAQ.

    If you can’t get it to work, you can give me a temporary level 8 account, and i will see if can find the problem.

    thomas your problem is quite easily solved. If you look at the source of the blank page you’ll see a line that says “Sorry there is no album where you are allowed to upload files”. It took me while to figure it out but the plugin will not automatically create a new album for you. What you need to do is simply go to “” click albums and click new. You already moved the wp-upload file in the right place as fars as i can tell (mine is in the coppermine dir). You should be able to upload files now

    Jan –

    How did you fix the problem for Thomas? I have the same error on my site. I can install and use coppermine fine but when I try using your program it give me the “Connection successful, but table not found. Invalid prefix ? (Not sharing the connection with WordPress)” like Thomas had. Maybe there are more of us with the same problem.

    The message is a little confusing. It will be changed in a next version. It means that all the database are correct, except for the table prefix, which seems to be different from the coppermine database prefix.

    If you are sure the prefix is the correct and you get this error, please give me a temporary account so I can find what is wrong and fix it. Thanks!

Viewing 14 replies - 1 through 14 (of 14 total)
  • The topic ‘Coppermine integration plugin for WordPress problems’ is closed to new replies.